Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is what I've done exactly.

I downloaded Minecraft for Linux from minecraft.net I tried running the file using both OpenJDK Java 7 Runtime and Oracle Java 7 Runtime The file opened fine both times and I logged in as so Then the screen went black and stayed that way.

I don't know what to do?

share|improve this question
    
Could you show the terminal output when running minecraft? –  MiJyn Nov 29 '12 at 6:19
    
It's okay now. I fixed it. Thanks anyways. –  Devon Nov 29 '12 at 22:15

1 Answer 1

For some wierd reason, i had the same problem until i installed the previous version of java, OpenJDK-java-6-runtime. Try to do that, and minecraft will run pretty well for you too.

use: (in terminal)

sudo apt-get install openjdk-6-jdk to install it, and then rightclick the minecraft file, and select run with Java 6

Good luck!

share|improve this answer
    
I fixed it now. Apparently I was using an older version of lwjgl (2.8.3). I went to www.lwjgl.org and downloaded the latest version (2.8.5). After that I replaced the old files with the new files and now it works. Thanks anyways. –  Devon Nov 29 '12 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.