Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After update to Kubuntu 12.10, I can no longer access configuration options in Kile from Settings->Configure kile (or whatever the menu entry was for configuration).

In fact, "Settings" menu has only five entries: "Define current document as master document", "System check", "Show side bar", "Show message bar", and "Toolbars shown."

I did a fresh install of Kubuntu 12.10 on one of my other computers, and same problem. I even tried adding the (unsupported) ppa:kile/stable, but the problem persists. Any ideas?

I need to access settings to set PDF Latex to use "modern" compilation mode, so that I can use synctex.

share|improve this question
up vote 11 down vote accepted

Try removing the user specific file for Kile. I had the same problem after I messed with the toolbars.

~$ rm ~/.kde/share/apps/kile/kileui.rc

These guys had the had the same problem. They suggest the folder ~/.kde4 where on my system 12.10 (64) it was in ~/.kde.

share|improve this answer
Thanks for your comment! I'll try that on Monday when I get back to my office. – William Dec 1 '12 at 7:06
OK, I can confirm that ajrichards' suggestion worked. Thanks! accepting the answer.... – William Dec 3 '12 at 21:17
Did not work for me with Ubuntu 12.10 64bit - but Erik's approach does the trick for me – Philippe Dec 27 '12 at 20:40
I had the same problem... and it worked, but now whenever I change the ui the same thing happens. How do I change the ui now ? – UnadulteratedImagination Dec 1 '13 at 17:23

My installation of Kile lost the entries in the settings dialogue as soon as I changed one item in any of the toolbars. My solution for this might help you out as well.

It appeared I could avoid this by adding the button "Configure Kile" to a toolbar.

This approach retains your personalised toolbars.

My sytem: Kile 2.1.0 / KDE 4.9.4 @ Kubuntu 12.04

share|improve this answer
Thank you, that actually works quite well. – William Apr 15 '13 at 19:12

Another way of getting system settings back is by resetting your toolbar: right click the toolbar, select "Configure Toolbars...", and then click the "Defaults" button on the lower left.

share|improve this answer

I've found another solution for this...

vim ~/.kde/share/config/kilerc

there I edited the MainWindow configuration, just search the word MainWindow using


and edited the keyword value named MenuBar. I founded it configured like this:


after that I switched to able.

Saved the file, re-launch Kile and worked perfectly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.