Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Quantal on my MBA. Wireless worked fine until I ran the first software-update and now it cant find the wireless driver. Wired works fine but I dont have root privileges on network and cant get software sources to open because of the security policy.

(I want to check if the Broadcom driver is selected.) Has anyone else experienced this problem, and if so, any idea on how to fix it?

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

Same problem here. Original 12.10 worked fine, but after update wireless network interface is missing on MacBook Air 4,2. After some digging and trying things out, I found that by going to "Software Source" and disabling the Broadcom additional driver and rebooting, my wi-if came back on.

share|improve this answer
    
That worked. Some issues with a package that had french characters in it breaking access to Software sources stop me from testing it for a while. –  Tahnoon Pasha Jan 10 '13 at 10:55
add comment

Disabling Broadcom proprietary driver BCM43224 brought back wifi for me as well, Macbook Air 11 from August 2012 / 8GB / i7 CPU. Ubuntu 12.10

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.