Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background: Brother HL-2270DW printer configured with my Xubuntu 12.10 over my home network. Whenever it finishes printing something, the fan keeps running for about 2 hours before going to sleep.

Question: Is there any way I can decrease this "awake" time, so that the fan stops running sooner? For example, is there a configuration file I am able to edit?

share|improve this question
    
Not a Ubuntu issue. Try Brother –  Ringtail Dec 17 '12 at 0:46
    
I posted this here because I figured that there was some way to control printers from Ubuntu, like CUPS, but CUPS can't change the sleep time. –  DaimyoKirby Dec 18 '12 at 3:57

2 Answers 2

up vote 6 down vote accepted

So I found the answer at a Launchpad question from someone experiencing a similar problem. After somehow starting to search for a "ppd" file as a possible solution, I stumbled on said Launchpad question.

So when I installed the lpr and cups drivers from the Brother site, it created a ppd file at /usr/share/cups/model, with the name of my printer model. So I opened cups, navigated to Administration -> Manage Printers -> Brother_HL-2270DW_series -> Administration/Modify Printer, chose Brother as the make, and added the ppd file from said location. This installed the correct drivers, giving me full access to all printer features, including sleep time!

share|improve this answer

Found this on Ask Ubuntu. People say printer configuration (sleep time...) works well with Original Drivers

share|improve this answer
    
No, that didn't work - I followed all the instructions, and it ended up with a "printer not connected" error when I tried to print a test page. So the only configuration I've gotten to work so far is using the generic drivers. –  DaimyoKirby Dec 18 '12 at 3:49
1  
This Might help. chadchenault.blogspot.in/2012/05/… –  465544 Dec 18 '12 at 4:01
    
Well, I followed the instructions (Both with 64-bit drivers and 32-bit drivers, even though I'm on 32-bit), but it didn't work. When I clicked "Find New Printers", however, two came up, and one of them had that "_pdl" thing. When I tried to print, it worked, but it didn't have an option to set the sleep time. I found the answer, and I think your suggestions helped me using some different parameters, and that led me to the solution, so thanks for your help! –  DaimyoKirby Dec 18 '12 at 4:44
    
Also, I'm not sure, but I'm think that blog's note about needing to make sure the connection was dnssd://blahblah._pdl-datastream._tcp.local/ is necessary. Again, thanks for helping! –  DaimyoKirby Dec 18 '12 at 4:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.