Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to Ubuntu 12.10, I have been unable to restart my Oracle virtualbox.

jan@jan-System-Product-Name:~$ sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv: command not found

Where do I go from here? Can anyone help, please?

I tried to install virtualbox via these commands:

echo "deb http://download.virtualbox.org/virtualbox/debian $(lsb_release -sc) contrib" | sudo tee /etc/apt/sources.list.d/virtualbox.list
wget -q http://download.virtualbox.org/virtu...racle_vbox.asc -O- | sudo apt-key add -
sudo apt-get update 
sudo apt-get install virtualbox-4.2

Attempts to install via package manager vbox would not start. These error reports are received:

Because the USB 2.0 controller state is part of the saved VM state, the VM cannot be started.To fix this problem, either install the 'Oracle VM VirtualBox Extension Pack' or disable USB 2.0 support in the VM settings (VERR_NOT_FOUND).

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

I installed the extension pack, no change in result.

I have added myself as user, but the error report says user must be added, when I redo add user, it says user is already added.

The following outputs were also received:  

Failed to open a session for the virtual machine Nuwe skelm. Implementation of the USB 2.0 controller not found!

I cannot access the USB 2.0 setting to disable it. Where do I go from here, please?

share|improve this question
    
try this: sudo apt-get purge virtualbox-4.2; sudo apt-get install virtualbox-4.2 –  MiJyn Nov 28 '12 at 19:48
1  
in case you have a previous version of virtualbox installed this needs to be purged too. –  Takkat Nov 28 '12 at 19:52
    
Have you downloaded the latest extension pack or are you trying to install and old one into a new Vbox version?. No joke it happened to me :(. –  Javier Rivera Nov 29 '12 at 8:04
    
See my answer below. The USB setting is in the VM settings, not inside the VM. –  nslntmnx Sep 26 at 13:21

2 Answers 2

First Remove Completely Virtualbox.

sudo apt-get purge virtualbox-4.2 

Remove other unnecessary packages.

sudo apt-get autoremove

Update packagelist.

sudo apt-get update

Reinstall Virtualbox

sudo apt-get install virtualbox-4.2 
share|improve this answer

I'm not using USB, so didn't need to install the extension pack. I just disabled the USB.

vboxmanage modifyvm VM_NAME_HERE --usb off

Then I started the VM. It worked great on all my VMs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.