Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First time ever today Firefox Version 3.6.13 freezed for me on Ubuntu 10.10 64bit.

I open Firefox normally but then nothing respond on the GUI.The only thing I can do is close it.
When Closed I try to re-open but the application still runs on the background
So I have to kill it manually along with Firefox-bin from the System monitor or kill pid command ..
I don´t know what caused this..I suspect Addons or maybe a proxy setting with polipo.
I also installed DockbarX this morning but it seems ok with Chromium now.

Same story after rebooting,
So I left it as it is to find a solution from AskUbuntu
What can I do now? Where do I check the Logs to locate the problem?
How do I get back my working Firefox without Re-installation ?
Any Suggestion is welcome.

share|improve this question
I also discuss some other useful firefox troubleshooting techniques in relation to a different question –  user76204 Dec 12 '12 at 14:12

4 Answers 4

up vote 5 down vote accepted

It sounds possible you have a problem with an Add-On causing an issue.

I would suggest attempting to start firefox in safe mode with all your addons etc disabled and see if that stops the application freezing on startup. You can do so by running the following command.

firefox -safe-mode

You should then get a dialog box with several options make sure that Disabled all add-ons is checked and click on Continue in Safe Mode. There are other options there to reset certain settings and features that you can also try if it turns out not to be an Add-On conflict. If that resolves the issue remember safe mode only applies for this session so you will now want to resolve which add-on is causing firefox to freeze.

First while in safe mode go to Tools > Add-Ons and disable all installed Add-Ons there that will make firefox run with no Add-Ons next time it is started in normal mode. At that point close firefox down and start it in normal mode to ensure it still runs without freezing and that all Add-Ons are indeed disabled.

Your next course of action if this is all working still is to attempt to enable each Add-On you have in turn, restarting firefox in between each to identify the Add-On which is causing firefox to freeze note it could also be a combination of Add-Ons so in the event that enabling only one at a time does not cause the symptoms next try these steps.

After running through every Add-On singly start enabling all your Add-Ons again restarting with each you enable until you produce the freeze, at that point you know that the last one you activated is conflicting with one of the others enabled prior. You can then use the safe mode trick to disable the others and try each of those candiates combined with just the last suspect Add-On you enabled to find the responsible pair of Add-Ons.

share|improve this answer
Yes it works! I input the safe mode command disable some supsected addons and Firefox was back and running.I accept this as the solution cause the way was faster.thanks –  Denja Jan 20 '11 at 0:58


share|improve this answer
You could have posted google.com/search?q=firefox+troubleshooting as well. Please add the relevant parts of the article, and refer to it in the end. –  Lekensteyn Jan 19 '11 at 21:18
I checked this link and was also very helpful although I could not find the culprit extension from the error console +1 –  Denja Jan 20 '11 at 1:03

At last!! My Firefox was back very quickly after I input this safemode command

firefox -safe-mode

But after uninstalling completely a couple of addon (Agoogle applications tracker and flash downloaders)
I checked my System Monitor and it was still running heavily (68%)

I was still missing the icing on the cake
Then I remembered this ¨amazing¨ startrek transporter animated persona that I wore from yesterday, this one combine with the ugly add-on made firefox run at 100% and freeze. `

Bad Firefox Personas could slow your overall Operating System performance/speed

Now I´am back to normal 10% system resource with both chromium and Firefox
running at the same time.
I´ĺl post the Firefox console error here:

alt text

share|improve this answer

I had the same problem on Ubuntu 13.04, and I solved it after I uninstalled unity-webapps-facebookapps and unity-webapps-youtube.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.