Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 lts. I used the BleedingEdge12_4_26.sh script which was recommended to me to install some more software.

This morning my update notification came up and when I tried to do an update I started getting errors about the package manager being broken. The package manager log revealed that libjack was the problem.

I tried to install it manually but this is what I get:

$ sudo apt-get install  libjack-jackd2-0
[sudo] password for jls: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  jackd2
The following packages will be upgraded:
  libjack-jackd2-0
1 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
1 not fully installed or removed.
Need to get 0 B/197 kB of archives.
After this operation, 3 072 B of additional disk space will be used.
(Reading database ... 207517 files and directories currently installed.)
Preparing to replace libjack-jackd2-0 1.9.8~dfsg.1-1ubuntu1 (using .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb) ...
Unpacking replacement libjack-jackd2-0 ...
dpkg: error processing /var/cache/apt/archives/libjack- jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb (--unpack):
 './usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

It seems like some kind of conflict but I am unable to decipher exactly what.

Any help would be much appreciated.

Thanks

Update: After some more research I tried this:

$ sudo apt-get clean
$ sudo apt-get update && sudo apt-get upgrade

which returned this:

Fetched 2 574 kB in 17s (144 kB/s)                                                                                                     
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libjack-jackd2-0 : Breaks: libjack-jackd2-0:i386 (!= 1.9.8~dfsg.1-1ubuntu1) but 1.9.8~dfsg.2-1precise1 is installed
 libjack-jackd2-0:i386 : Breaks: libjack-jackd2-0 (!= 1.9.8~dfsg.2-1precise1) but 1.9.8~dfsg.1-1ubuntu1 is installed
E: Unmet dependencies. Try using -f.

So i tried this:

$ sudo apt-get -f install

which returned this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libjack-jackd2-0
Suggested packages:
  jackd2
The following packages will be upgraded:
  libjack-jackd2-0
1 upgraded, 0 newly installed, 0 to remove and 22 not upgraded.
1 not fully installed or removed.
Need to get 197 kB of archives.
After this operation, 3 072 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ppa.launchpad.net/dns/sound/ubuntu/ precise/main libjack-jackd2-0 amd64 1.9.8~dfsg.2-1precise1 [197 kB]
Fetched 197 kB in 1s (101 kB/s)            
(Reading database ... 207517 files and directories currently installed.)
Preparing to replace libjack-jackd2-0 1.9.8~dfsg.1-1ubuntu1 (using .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb) ...
Unpacking replacement libjack-jackd2-0 ...
dpkg: error processing /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb (--unpack):
 './usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

jls@jls-HP-Pavilion-g6-Notebook-PC:~$ sudo dpkg --configure -a
dpkg: error processing libjack-jackd2-0:i386 (--configure):
 libjack-jackd2-0:i386 1.9.8~dfsg.2-1precise1 cannot be configured because libjack-    jackd2-0:amd64 is in a different version (1.9.8~dfsg.1-1ubuntu1)
Errors were encountered while processing:
 libjack-jackd2-0:i386

So I tried to remove the conflicting package;

$ sudo apt-get remove --purge libjack-jackd2-0

And ended up with this;

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gstreamer0.10-plugins-good : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
 libasound2-plugins : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
 libavdevice53 : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
 libfluidsynth1 : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
 libmlt4 : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
 libportaudio2 : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
 librtaudio4 : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
 librtmidi1 : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
 lmms : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or libjack-0.116
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

And now I'm really stumped :(

share|improve this question

1 Answer 1

http://www.iasptk.com/ubuntu-fix-broken-package-best-solution

After trying

sudo dpkg --configure -a

and

sudo apt-get install -f

the problem of a broken package still exist the solution is to edit the dpkg status file manually.

$ sudo gedit /var/lib/dpkg/status    (you can use vi or nano instead of gedit)
Locate the corrupt package, and remove the whole block of information about it and save the file.
share|improve this answer
    
Thanks ptheo. I commented out the libjack block and tried another update but got this: Fetched 2 291 kB in 2min 17s (16,7 kB/s) Reading package lists... Error! W: Failed to fetch archive.ubuntu.com/ubuntu/dists/precise/InRelease W: Some index files failed to download. They have been ignored, or old ones used instead. E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/dpkg/status E: The package lists or status file could not be parsed or opened. –  user111266 Nov 28 '12 at 11:40
    
Looks like you forgot to remove something in the block. I tried ptheo solution and it's the only one that worked for me (after many other tries and reading many other questions here about an i386 package stuck in an half-configured state, just because the amd64 version was in a more recent version...). –  Claude Brisson Dec 1 '12 at 22:35
    
Thanks Claude. You were right. There was a second libjack block further down in the file. –  user111266 Dec 3 '12 at 12:38
    
Please avoid posting the same answer in multiple places. When tempted to do so, this typically means: (1) the answer should be customized to account for what is different about the different questions, (2) one question should be flagged for closure as a duplicate of another question (you can flag posts with 15 reputation), (3) the answer should really be a comment, or (4) the answer should be posted in the most appropriate place, and one-line comments posted on the other questions summarizing and linking to it. –  Eliah Kagan Jan 22 '13 at 0:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.