Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I could successfully connect to network through livecd but through my hard disk it is not possible.

:~$ sudo ifup eth0
ifup: interface eth0 already configured

:~$ sudo lshw -class network
  *-network DISABLED      
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 05
       serial: ff:ff:ff:ff:ff:ff
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full latency=0 link=no multicast=yes port=MII speed=100Mbit/s
       resources: irq:40 ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff

:~$ sudo /etc/init.d/networking restart
 * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
 * Reconfiguring network interfaces...                                          RTNETLINK answers: No such process
SIOCSIFFLAGS: Cannot assign requested address
SIOCSIFFLAGS: Cannot assign requested address
RTNETLINK answers: Network is down
run-parts: /etc/network/if-up.d/avahi-autoipd exited with return code 2
                                                                         [ OK ]

Please let me know if you need more information.

share|improve this question
add comment

2 Answers

I had a similar issue with a Realtek Ethernet controller. I had a different model, but it exhibited similar behavior to what you are describing. I was able to get it connected by running :

sudo ifconfig eth0 up

This command had to be run Everytime I started the computer, so you might find it beneficial to make the command a bash alias or shell script. If you need a guide for that, there are plenty to be found online.

share|improve this answer
add comment
$ sudo ifup eth0
ifup: interface eth0 already configured

Seems eth0 is already up. Make sure that the configuration of eth0 is correct either in /etc/network/interfaces or using the Connection Editor, depending on whether you are using ifup or NetworkManager, respectively.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.