Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm getting this error when I run gtk-redshift from the CLI (it just doesn't start if I start it from the GUI):

(process:3862): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed

If I run redshift, I also get the same error as above, followed by this:

Segmentation fault (core dumped)

I'm running redshift version 1.7 and Xubuntu 12.10.

share|improve this question
add comment

1 Answer

up vote 8 down vote accepted

You can try to create a config file to avoid the crash..

Create a file named redshift.conf and save it into /home/user/.config folder.
Here you have an example to create the config file.

; Global settings
[redshift]
temp-day=5700
temp-night=3500
transition=1
gamma=0.8:0.7:0.8
location-provider=manual
adjustment-method=vidmode

; The location provider and adjustment method settings
; are in their own sections.
[manual]
lat=-34.6
lon=-58.3

;screen
[vidmode]
screen=0

To know the coordinates for your city you can use itouchmap. just search for your place and write down the numbers.
eg: My city Buenos Aires is lat=-34.6 and lon=-58.3

Once you have your redshift.conf file , run the application and see if it works. You can find additional information about commands,config file, values in Redshift web page...

I hope this will solve your problem.

Regards.

share|improve this answer
    
Thanks a lot, that solved my problem! –  srunni Nov 28 '12 at 18:00
1  
@Roman Raguet: Thanks! I just want to add that this worked for Lubuntu (my version is 13.10). It seems the name of the file to be created should be "redshift.conf" –  pablofiumara Nov 3 '13 at 18:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.