Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My brightness control doesn't work with a fresh install of 12.10 (brand new laptop). It is set to the brightest setting when I boot up and when I try to change it, I see the notification bar come up but the brightness doesn't actually change. I've tried all the solutions I could find around the Internet but none of them work. Things I have tried include:

Editing /sys/class/backlight/acpi_video0/brightness

In /usr/share/X11/xorg.conf.d/10-brightness-control.conf: Option "RegistryDwords" "EnableBrightnessControl=1"

In /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

There is no xorg.conf file in 12.10 that I have found, so the solutions that suggest editing that file don't do me a whole lot of good.

I am currently using the Nouveau driver, but switching to the Nvidia proprietary drivers made no difference.

Any other ideas? When is this bug going to be fixed? With all the reports I've come across I would think it would get a lot of attention. Thanks.

share|improve this question

3 Answers 3

Did Ubuntu backported patches from Kernel 3.7 to 3.6? That could be the cause, see here: https://bugzilla.kernel.org/show_bug.cgi?id=51231

Try to use the brightness slider vom "System Settings" > "Brightness & Lock" in GNOME.

share|improve this answer
    
Tried the slider, no change. –  Matt Dec 5 '12 at 19:29

I had a similar problem on my thinkpad W530. I finally found a solution here:

http://blog.pearce.org.nz/2012/08/enabling-external-monitor-on-lenovo.html

These days X automatically configures itself, so you can't just edit the xorg.conf file, you instead need to add a section to a file in /usr/share/X11/xorg.conf.d/ and X will include that section in the configuration that it automatically generates.

So to get the screen brightness keys working with your Nvidia graphics card, create a file in the xorg.conf.d directory, e.g:

sudo gedit /usr/share/X11/xorg.conf.d/10-nvidia-brightness.conf

Paste the following into the file:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K1000M"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection
share|improve this answer
    
+100... i've been switching to a virtual console to use my brightness controls for an embarrassing amount of time –  ben author Sep 4 at 2:52

Have you updated grub (sudo update grub) after you edit /etc/default/grub and rebooted?

If above not working Also try with acpi_backlight=vendor only.

If it is a thinkpad thinkpad-acpi.brightness_enable=1 parameter is also required.

You can check to see if your system uses the thinkpad-acpi driver by using the following command:

lsmod | grep thinkpad_acpi

Check this page (See first paragraph & Diagnostic Techniques)


Update :

Another thing I just show, have you edited /etc/X11/xorg.conf file? in your question you are pointing to some other location which I never heard of. Execute nvidia-xconfig to generate config file, if /etc/X11/xorg.conf doesn't exist.

Secondly, try one solution at one time. if that doesn't work revert back and reboot then try other solution.

Another workaround could be

Try following for paths shown by ls /sys/class/backlight/*/brightness and replace accordingly.

example paths will be like

/sys/class/backlight/acpi_video0/brightness
  1. For the above path Get the maximum brightness:

cat /sys/class/backlight/acpi_video0/max_brightness

Try a lower value to set the brightness, say output is 16 so I will try with half of it

echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

If this works, make this happen in each login automatically by doing the following

sudo gedit /etc/rc.local

Enter this line just before exit 0. It should look like

echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness
exit 0

Also you can try with xdotool Install xdotool

share|improve this answer
    
Thanks for pointing me to the diagnostics page, but none of the ideas there worked either. I filed a bug on Launchpad as per the instructions there. Any other suggestions? –  Matt Nov 28 '12 at 7:58
    
See the updated answer –  Web-E Nov 28 '12 at 8:16
    
I tried all those ideas too. None of them changed the brightness. I noticed this output from dmesg. Does any of it point you to another theory? Thanks so much for looking at this with me. –  Matt Nov 28 '12 at 16:53
    
[ 2.544835] thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness control, supported by the ACPI video driver [ 2.544838] thinkpad_acpi: Disabling thinkpad-acpi brightness events by default... [ 2.549966] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one [ 2.589309] ACPI Warning: 0x0000000000000460-0x000000000000047f SystemIO conflicts with Region _SB_.PCI0.LPC_.PMIO 1 (20120320/utaddress-251) [ 2.589323] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver –  Matt Nov 28 '12 at 17:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.