Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sony VAIO with Insyde H2O EFI bios will not boot into GRUB EFI

The answer to this question was immensely helpful to me and my new Vaio Z3. The issue that I am having now is that after replacing bootmgfw.efi with grubx64.efi and renaming, it boots directly to grub console. I dont even get a menu where i can chose ubuntu. I tried putting a grub.cfg file next to the new bootmgfw.efi(grubx64.efi), no go?

Any ideas how i can get the renamed grubx64.efi to find all the rest of the grub stuff outside of the ESP in my linux parition?

Or do i have to move all grub files to /EFI/Microsoft/Boot on ESP?

Thank you!

share|improve this question
add comment

3 Answers

If you're using the grubx64.efi file from Ubuntu, in theory it should be looking on your Ubuntu /boot/grub directory for its support files. If it's not finding them, then I'm not sure what's wrong. If you've built GRUB from source code or installed in some other way, though, you might need to copy all its support files, as you suggest.

Another alternative is to install rEFInd as EFI/Microsoft/boot/bootmgfw.efi on the ESP and leave GRUB where it is (presumably EFI/ubuntu/grubx64.efi). With a little extra configuration (described on the rEFInd Web page), you should even be able to bypass GRUB completely, if it's giving you problems.

More broadly, you may want to check out my Web page on EFI boot loaders, which includes information on boot loader installation and at least the basics of configuring all of them. (GRUB 2 is the hardest in this respect. It's only easy when the distribution installer gets it right.)

share|improve this answer
add comment
  1. Run Boot-Repair from a liveCD/liveUSB
  2. Click the Recommended Repair button. (this will automatically install correct parameters for grub-efi, including SecureBoot parameters if needed, and renaming the EFI files in case the UEFI firmware is locked to Windows files). Indicate the URL that will appear if any problem.

Boot-Repair

share|improve this answer
add comment

I have found that putting grub.cfg into /EFI/ubuntu works, even when grubx64.efi is in /EFI/Boot

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.