Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is making me crazy.

After upgrading to Ubuntu 12.10, Skype 4.1.0.20 can't use my web cam microphone anymore.

  • I can record correctly from the web cam microphone using the sound recorder
  • the web cam microphone is selected in the global sound settings and working in any other application.
  • Also tried to start skype with LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype and LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so /usr/bin/skype

No matter what, Skype will keep using the front panel microphone for audio capture. Mic was working fine with Ubuntu 12.04 before I upgraded to 12.10.

share|improve this question

1 Answer 1

up vote 14 down vote accepted

Solved with pavucontrol. I had already tried the pulseaudio volume control, but you need to do a particular thing to make it work.

First, install pavucontrol:

sudo apt-get install pavucontrol

Then start it:

pavucontrol

You'll get the volume control window. Now, you could go to "Input devices" and select the webcam microphone as your input source: THIS WON'T WORK. This is how you do have to it:

  • Click on the "Recording" tab. This tab shows the applications that are capturing audio in that very moment, so it will probably be empty.
  • Start skype then call the Echo / Sound Test Service (or anyone you like who will answer)
  • When the other party answers, Skype begins capturing audio and will be shown in the "Recording" tab of the pulseaudio volume control window
  • From the "Input from" drop down list, select your webcam

And voilà, you'll get your microphone back.

Alternatively, as described in SkypeTroubleshooting

  • [..] go into the Skype Options menu - Sound Devices
  • remove the tick at: Allow Skype to automatically adjust my mixer levels.
  • Click Apply.
  • Readjust the sound mixer controls (pavucontrol input devices will work now).

This worked fine for me.

share|improve this answer
    
for me, unmuting the microphone was enough (under the 3rd tab) –  BЈовић Jan 11 '13 at 21:44
    
@f.cipriani thanks for the solution .. it worked for me .. but when i logout/restart, the changes revert .. is there a way to make this permanent? –  Abhinav Aug 20 at 13:57

protected by Community Feb 3 '13 at 3:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.