Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I'm new in Linux and I need your help :)

Every time when i type sudo apt-get update it shows:

alphaog@alphaog-HP-Pavilion-DV7:~$ sudo apt-get update
E: Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/ricotz-testing-precise.list
E: The list of sources could not be read.

I tried

gksu gedit /etc/apt/sources.list

and put # in front third line but it still doesn't work. Please Help! :)

share|improve this question
    
Can you post a pastebin of your sources.list? –  DaimyoKirby Nov 27 '12 at 21:20
    
That was the wrong file to edit, see answers. –  david6 Nov 27 '12 at 22:07
    
If you have an answer that works, please accept it. –  VedVals Dec 4 '12 at 7:54
add comment

2 Answers

Please provide output from: (add detail to your question)

cat /etc/apt/sources.list.d/ricotz-testing-precise.list

You will likely need to remove the third line from this file:

gksudo gedit /etc/apt/sources.list.d/ricotz-testing-precise.list
  • Enter your password (if asked) and wait for editor.
  • Delete the 3rd line. The "ain" is a corrupted " main".
  • Save, and Close the file.

Then run:

sudo apt-get update && sudo apt-get upgrade
share|improve this answer
    
when i type cat /etc/apt/sources.list.d/ricotz-testing-precise.list –  user111172 Nov 27 '12 at 22:13
add comment

This is easy to fix.

apt-get gives you a warning about where the problem exists.

Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/ricotz-testing-precise.list

Open the file with an editor (eg: gedit). You will need root privileges to edit the contents.

Run this command in terminal

gksudo gedit /etc/apt/sources.list.d/ricotz-testing-precise.list

and delete the word 'ain' . Save the file and run again

sudo apt-get update
share|improve this answer
    
Thanks good sir :D it's working now –  user111172 Nov 27 '12 at 22:16
    
@user111172 Glad it works ! Please mark the answer as the correct answer. –  NikTh Nov 27 '12 at 22:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.