Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have my 7.1 soundcard set to stereo and plugged in two stereo thingies (a. my desktop speakers b. my stereo) to the front respectively rear plug. Now I would like to an easy way to mute/volume control them independently - gui if possible.

If I set my soundcard to 4.0, the pulse audio mixer gives me sliders for front and back but the problem is that's the input signal. so if i mute the front there and I'm listening to stereo everything remains silent. But what I'd have liked in that scenario would be the front to be silent and the back playing the full stereo signal.

Is there a way to do that or something similar?

share|improve this question

2 Answers 2

The mixers that ship in Ubuntu are all very flimsey in my opinion but there are a couple of good options that are simple to install.

  1. ALSAMixer is usually the first port of call for telling people how to fix muted channels, etc but it's a fairly robust text-mode mixer. I would suggest this over the GUI alternatives (gnome-alsamixer as one example) because they lack polish and that makes them harder to use.

    If it's not already installed, it's as simple as:

    sudo apt-get install alsamixer
    alsamixer
    

    Alsamixer

  2. padevchooser is another option. It's a lot more than just a mixer - it's a whole suite of tools for managing pulseaudio. Rather than being console-based

    sudo apt-get install padevchooser
    padevchooser
    

    When it's running you should see a new icon in your Notification Area (near the clock). Click it and select Volume Control. Under Output Devices you should be able to manage the volumes on a per-channel basis.

    padevchooser's volume control

    You might want to add padevchooser to your list of start-up applications (in System -> Preferences)

share|improve this answer
1  
thanks but i was looking for something a bit more elaborate (making sure both outputs get the same(!) stereo-signal no matter what the source. I found a solution in thomasa88.blogspot.com/2008/11/… - it's important though to take into account what the first comment to that tutorial says. (generally ENABLING mixing in daemon.conf and only disabling it in the two stereo sinks in default.pa by adding remix=no. That way they work as expected with stereo signals and get the proper ammount of other surround channels mixed in. –  someguy1984 Jan 21 '11 at 10:21
    
padevchooser (pavucontrol alone does the trick too. easily accesible by way of the pulseaudio-mixer-applet) can then tell different players to use different outputs on the same card (seeing as they appear as separate devices to the mixer) edit: oh and for anyone reading the tutorial i posted: lines that are commented out and posted anyway are usually lines that are already in the two files and have to by all means be commented out - especially the automatic loading of modules/devices) –  someguy1984 Jan 21 '11 at 10:23

You need pavucontrol:

apt-get install pavucontrol

This is basically pulse audio advanced controls featuring single channels mixing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.