Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
disable the cdrom in Ubuntu 11.10 OS

I have no use for a CD drive, ever. Yet it exists, consumes power, opens inadvertently when in its case or in my bed and makes noise whenever computer sleeps, wakes, shuts down or boots.

I would like to shut it out of existence. This will also be true if my next laptop has one too. But in this particular case I don't have the password to access the BIOS (hope it's not required).

udisks --show-info /dev/sr0 shows

drive:
    vendor:                    HL-DT-ST
    model:                     HL-DT-ST DVDRAM GSA-T50L
    revision:                  SC04
    serial:                    MKS92IH3934
    WWN:                       
    detachable:                0
    can spindown:              0
    rotational media:          Yes, unknown rate
    write-cache:               unknown
    ejectable:                 1
    adapter:                   /org/freedesktop/UDisks/adapters/0000_3a00_3a1f_2e2

I think detachable: 0 indicates what I want is not possible but I feel like I'm probably not the only one to find a CD drive useless and annoying. So maybe someone has an idea on how to do this.

I was about to test playing with files in /sys/bus/scsi/devices/1:0:0:0/block/sr0/power but I'd like to avoid messing with stuff I can't really handle and that could make it unmountable but still annoying or worse.

Feel free to ask for more details.

share|improve this question

marked as duplicate by psusi, belacqua, Ringtail, Javier Rivera, hhlp Nov 28 '12 at 10:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
So unplug it?.. –  psusi Nov 27 '12 at 20:09
    
It should be a solution common to Ubuntu/Linux, not any particular hardware, maybe I have a laptop that's really hard to open like a mac or some other stupid computer... –  sinekonata Nov 29 '12 at 10:51
1  
Note that while you aren't actively using it, it draws virtually zero power, and the only way to eliminate that trickle is to unplug it. –  psusi Nov 29 '12 at 14:40
add comment

1 Answer 1

I used the following from this Question

Its a little risky but it works.

Backup the file /etc/group

press ctrl+alt+t and type gksudo gedit /etc/group

Remove the users from cdrom(in this screenshot tachyons is the user name)

Image from previous mentioned question

save the file and restart your pc

share|improve this answer
    
Thanks a lot I'll look into that today, but from the looks of it, that will not disable it completely. –  sinekonata Nov 29 '12 at 10:54
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.