Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I start my computer and login the desktop icons do not show. However, when I open the desktop folder in my file manager, they appear. How can I make them show right from the start?

I use Nemo as file manager, Unity is my desktop environment and the whole thing runs on Ubuntu 12.10 Quantal Quetzal.

share|improve this question
1  
Does Nemo also handle the Desktop?, possibly it is because it isn't running until you start it by opening it, there's nothing drawing your desktop, that could be it. –  Uri Herrera Jan 6 '13 at 21:27
    
I don't know, how do I check? –  Daan Wilmer Jan 8 '13 at 0:51
add comment

3 Answers 3

up vote 1 down vote accepted

I think the problem is that Nemo doesn't start automatically. To check this, as soon as you log in open "system monitor" and control if "Nemo" is one of the active processes. If not you should go to "Applications boot", or something similar, and add an entry, call it "Nemo" and fill in as a command "nemo".

share|improve this answer
    
Running nemo gave me not only my desktop icons, but also a nice file manager window. Fortunately, nemo has the '-n' option that hides that window. Anyway, thanks for you answer. I'm afraid I'm too late awarding the bounty, or you'd have it. I'd reopen it if I could to assign it to you, but I think I don't have enough rep for that... –  Daan Wilmer Jan 16 '13 at 23:44
    
checks meta ah, I need to double the bounty - more rep than I currently have here. Sorry :(. (double comment because it took more than five minutes to figurate that out) –  Daan Wilmer Jan 16 '13 at 23:57
add comment

Under your system settings you could find default applications settings . there you can change your file manger from nautilus to nemo .

then re login .

hope that helps .

share|improve this answer
add comment

Make sure the Advanced Settings/ Gnome Tweak tool is installed . There is a new version in 12.10 for Gnome 3.6 .I don't know if it would have been replaced during the upgrade since I did a clean installation . That is where the desktop icons and nautilus control desktop settings are.

http://ubuntuforums.org/showthread.php?t=2073978#2

share|improve this answer
    
I have it, and under Desktop the "Let File manager handle the desktop" switch is on. Turning it off gives me no icons at all. –  Daan Wilmer Jan 8 '13 at 0:51
    
Sorry I meant to get you to install ubuntu tweak, not gnome tweak. I think they are different apps for different desktops. Let me know if you have any luck. –  dibs Jan 8 '13 at 1:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.