Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay, in my GUI, Ubuntu only allowed me to set a resolution for 1360x768 and 1024x768 even though I know darn well my P76 monitor is capable of 1280x1024.

So, after a little investigation I used cvt and xrandr to figure out that I can add these lines to my /etc/gdm/Init/Default file (first four lines are actually one line, I've just split it for readability):

xrandr --newmode 1280x1024  109.00
                 1280 1368 1496 1712
                 1024 1027 1034 1063
                 -hsync +vsync
xrandr --addmode VGA1 1280x1024
xrandr --output VGA1 --mode 1280x1024

Now, that works fine, I find that the login screen is actually in 1280x1024.

However, when I actually log in, it reverts to 1024x768 which is a serious pain.

The output from xrandr shows:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mmx0mm
   1360x768       59.8  
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9     59.9  
   1280x1024      59.9  

so I'm guessing that it's the fact the preferred resolution is 1024x768 (since that has the * next to it) that's causing my reversion to that resolution. Executing:

xrandr --output VGA1 --mode 1280x1024

from a terminal window fixes it but I'd prefer an automatic solution.

How do I set the preferred resolution to be 1280x1024 (if that is indeed my problem)?

Can this be done with another xrandr command and should this be in /etc/gdm/Init/Default or somewhere else?

share|improve this question
    
Here is the answer unix.stackexchange.com/questions/47749/… –  sepdau Jun 19 at 3:29

1 Answer 1

up vote 3 down vote accepted

First, you should try to change the resolution using System->Preferences->Monitors, and then reboot. It's likely that it's stored somewhere and it will be restored it at login.

If it doesn't work you can add the xrand command to the items in System->Preferences->Start up Applications.

You will only need to add the last line:

xrandr --output VGA1 --mode 1280x1024

The files is /etc/gdm/Init/Default are executed when the gdm (the login window) starts, not when a session loads.

share|improve this answer
    
Actually, your first solution was the right answer. It looks like the GUI was remembering the fact that I'd set the resolution to be 1024x768 at some point. Once I changed that to 1280x1024 and rebooted, it maintained that resolution just fine. –  paxdiablo Jan 19 '11 at 8:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.