Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Ubuntu onto a 16GB flash-drive. I am not talking about a liveUSB, I mean I installed full Ubuntu onto the drive. My problem is that when I have tried booting from the device, all I get is the black screen with the flashing "_" in the top left corner. This persists for at least 15 minutes (at which point I give up). I outline my process for creating the USB below. My question is what exactly could be causing this, and how can I fix it?

From a different liveUSB I chose the install option, after the timezone info and others, I chose "Something Else" for installation type. On the single partition of my flash drive, I chose "ext2 file system", checked the format drive box, and set the mount point to "/"(the root). After warning me about not having a swap partition (which I was told would not be a problem), I went through the rest of the install without a single issue. But now when I boot from the drive, I get the persistent blank screen.

share|improve this question
where did you download the install file? sometimes the torrents are more reliable because the download size is large. – philshem Nov 27 '12 at 3:28
I used pendriveLinux to make a different drive bootable, and used that for the installation. The ISO came directly from the Ubuntu main website downloads section. – Daniel Marchese Nov 27 '12 at 3:29
It's problem of bootloader, You have to fix this using this documention – K.K Patel Nov 27 '12 at 4:02
Am trying that now, will get back to you when I'm done. – Daniel Marchese Nov 27 '12 at 4:18
My internet connection is running at a snail's pace so this might take some time. – Daniel Marchese Nov 27 '12 at 4:35
up vote 1 down vote accepted

Alright guys, I got everything to work. I'm still not sure why it wasn't working earlier, but I basically found a way to partition my flash drive and changed the file system to ext4 and there were no more problems. The install is working just fine.

share|improve this answer
What was the file system prior the partitioning in your case? – Gediminas Jeremiah Gudelis Aug 13 '13 at 4:58

I had a similar problem installing Ubuntu on a Dell XPS 8500. The problem was a missing driver for the video card (in my case an nvidia geforce gt 620).

The solution was to boot into recovery mode (you may need to hold down shift while booting to get grub menu), then select "drop to root shell prompt" and type "restart" then return. If all goes well you will get the log in screen. Log in and install drivers. Hopefully that fixes it.

share|improve this answer
I'll give it a try and see what happens. – Daniel Marchese Nov 27 '12 at 3:57
Unfortunately no dice. Immediately after selecting the flash drive to boot from in the BIOS, it goes straight to the blank screen and never actually makes it to grub (as far as I'm aware) Unfortunately holding shift did not move me to grub either. Even holding shift while selecting the boot device doesn't get me to the menu. – Daniel Marchese Nov 27 '12 at 4:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.