Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have searched around the forums and tried a number of solutions but nothing I have tried has fixed my problem. Here is the terminal info

john@ubuntu:/var/lib/dpkg$ sudo apt-get install python-captcha
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/384 kB of archives.
After this operation, 516 kB of additional disk space will be used.
(Reading database ... 182992 files and directories currently installed.)
Unpacking python-captcha (from .../python-captcha_0.4-1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/python-captcha_0.4-1_all.deb (--unpack):
 trying to overwrite '/usr/share/pyshared/Captcha/', which is also in package python-pycaptcha 0.4-1~precise1
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question

It appears that you have installed python-pycaptcha (maybe from a PPA), which can't be installed at the same time as the system python-captcha. See, if this fixes your problem:

sudo apt-get purge python-pycaptcha python-captcha+
share|improve this answer
Oh okay thanks. I was told to install pycaptcha and also saw python-captcha, and thought what the hell python-captcha might help as well. – CommandrKeen Nov 29 '12 at 2:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.