Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Remmina to connect to a remote desktop. I was constantly getting errors and handled it by deleting the content of: /home/zxy/.freerdp/known_hosts After that I could successfully connect to the remote desktop 2 times but now I am getting the following error could not find a solution:

Remmina plugin RDP (type=Protocol) registered.
Remmina plugin RDPF (type=File) registered.
Remmina plugin RDPS (type=Preference) registered.
Remmina plugin VNC (type=Protocol) registered.
Remmina plugin VNCI (type=Protocol) registered.
Remmina plugin SFTP (type=Protocol) registered.
Remmina plugin SSH (type=Protocol) registered.
connected to
The hostname used for this connection ( 
does not match the name given in the certificate:
A valid certificate for the wrong name should NOT be trusted!
SSL_read: I/O error

How can I solve this problem?


share|improve this question

I copied the .remmina files back over when upgrading from 11.10 to 12.04

I found that this is happening only on Windows 2008. Possibly a RDP6 issue.

This was solved because security somehow got reset to 'Negotiate'. I changed Advanced/Security to 'RDP', and all is working again.

share|improve this answer
This error can also appears while connecting from Debian to Windows 7 by using the command xfreerdp -u <username> <hostIP> -d hostdomain. For me it worked by adding the parameter -sec-nla, see – strpeter Dec 24 '14 at 6:55

If you issued the vpa certificate and it is the right one for the machine you are connecting, the error is due to you accessing the machine by IP and not using the vpa hostname. If you want to connect using the IP you need to make a certificate with the IP as Commom Name.

It is possible you changed the hostname of the machine you are connecting to and it can't be trusted anymore using this certificate.

To have certificate working, you need to have the remote machine hostname matching the one on the certificate and you need to use this name to connect to it.

share|improve this answer

I also changed to RDP from Negotiate in Advanced/Security and this fixed the Certificate Message I was getting that was keeping me from connecting remotely to a machine running Windows 7.

share|improve this answer
This is more of a comment than an answer. Can you please edit any useful information you have into one of the existing answers? – Tom Brossman Jan 20 '13 at 7:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.