Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I dualboot 12.10 and Win7. Both OSs are on the primary SSD while all commonly used data (documents, movies, music, profiles etc) is on a secondary NTFS-formatted HDD.

Since I needed the NTFS drive to automatically mount in Ubuntu right at startup, I downloaded ntfs-config and set it to automount my NTFS drive.

Problem is, I also accidentally told it to automount my external hard drive (which is also NTFS formatted). When booting up Ubuntu, it now checks for the presence of that drive every single time, which is getting annoying 'cause I don't always have it connected.

I've tried un- and reinstalling ntfs-config, telling it to not automount the external HD, but to no avail.

Any suggestions?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

the file /etc/fstab contains all the drives/partitions that will be automatically mounted at boot time, so its just matter of removing the corresponding entry (there should be 1 line entries).

to do that, open the file with

sudo gedit /etc/fstab

and remove the corresponding line of your external drive, if unsure, paste the content of your file /etc/fstab so we call assist you in which line to delete.

share|improve this answer
    
So the relevant line in fstab is this here: #Entry for /dev/sdc1 : UUID=42ACEDE7ACEDD607 /media/timon/Volume ntfs defaults,nls=utf8,umask=0222,nosu‌​id,nodev 0 0 should I simply delete it? –  Timon Nov 26 '12 at 23:29
    
yep, if you want to go safe in case you want to add the line later, just comment out that line (add a # sign at the begining of the line) to disable that entry, save the file and reboot –  Sam Nov 26 '12 at 23:32
    
Thanks, that did the trick! would vote you up if I could :) –  Timon Nov 27 '12 at 1:34
    
Actually, I have to go back on my previous statement. I'm pretty sure it worked on the first try, but not since then. My fstab in it's entirety now reads: #Entry for /dev/sda5 : UUID=8b874f66-bd72-4d7d-8dc5-d96078be96ed / ext4 relatime,discard,errors=remount‌​-ro 0 1 #Entry for /dev/sda3 : UUID=19B7DF4F45968595 /media/timon/Storage ntfs-3g defaults,nosuid,nodev,locale=‌​en_US.UTF-8 0 0 #Entry for /dev/sda2 : UUID=6AF4BC9FF4BC6F47 /media/timon/Windows7_OS ntfs-3g defaults,nosuid,nodev,loc‌​ale=en_US.UTF-8 0 0 #Entry for /dev/sda6 : UUID=6fb80f56-ec16-4569-b9c1-ee4baa8722ca none swap sw 0 0 –  Timon Nov 27 '12 at 2:33
    
Nevermind, after a couple more reboots it now works perfectly. Thank you for your help! –  Timon Nov 27 '12 at 2:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.