Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install cuds-5.0 on the new ubuntu 12.10 server. But I have some errors for that. When I try to make the Makefile in sample code. It told me *"nvcc fatal : Unsupported gpu architecture 'compute_35'"* Command and output is as following.

shi@dodo:~/NVIDIA_CUDA-5.0_Samples$ **nvcc -V**
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2012 NVIDIA Corporation
Built on Thu_Apr__5_00:24:31_PDT_2012
Cuda compilation tools, release 4.2, V0.2.1221

Output:

shi@dodo:~$ **cat /proc/driver/nvidia/version** 
NVRM version: NVIDIA UNIX x86_64 Kernel Module  304.54  Sat Sep 29 00:05:49 PDT 2012
GCC version:  gcc version 4.4.7 (Ubuntu/Linaro 4.4.7-2ubuntu1) 
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Your command line is showing that, even though you're invoking nvcc from the CUDA 5.0 directory, you end up starting the CUDA 4.2 compilation tools. This version does not support compiling for compute capability 3.5.

So, your primary issue is that you are not invoking the correct compiler. Also, do you have a device of compute capability 3.5? That would be a device based on the new GK110 chip. I think the only card available right now is the Tesla K20.

If you don't have a K20 card, you'll have to compile for a lower compute capability. That is, alter "compute_35" to, for instance, "compute_20", for a Fermi based card. This is regardless of which compiler you end up using.

share|improve this answer
    
Well, thank you so much and I solved the question. –  user110921 Dec 4 '12 at 22:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.