Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a fresh install of 12.10 and are now left wondering how to set mplayer as a global default application for video. I created a mplayer.desktop and added the same categories as totem has, however still no luck selecting it from the detailed Settings.

A similar problem is with thunderbird, which Id like to set as default calendar app. However I can only select gedit, for whatever reasons.

Any help would be very much appreciated!

Thanks

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Find a movie file, right click properties, open with…, set default.

Repeat for each movie file format.

TO set it as default, modify your mplayer.desktop like this:

[Desktop Entry]
Version=1.0
Name=Mplayer media player
GenericName=Media player
Comment=Read, capture, broadcast your multimedia streams
Exec=mplayer %U
TryExec=mplayer
Icon=mplayer
Terminal=false
Type=Application
Categories=AudioVideo;Player;
MimeType=video/dv;video/mpeg;video/x-mpeg;video/msvideo;video/quicktime;video/x-anim;video/x-avi;video/x-ms-asf;video/x-ms-wmv;video/x-msvideo;video/x-nsv;video/x-flc;video/x-fli;application/ogg;application/x-ogg;video/x-ogm+ogg;audio/x-vorbis+ogg;application/x-matroska;audio/x-matroska;video/x-matroska;video/webm;audio/webm;audio/x-mp3;audio/x-mpeg;audio/mpeg;audio/x-wav;audio/x-mpegurl;audio/x-scpls;audio/x-m4a;audio/x-ms-asf;audio/x-ms-asx;audio/x-ms-wax;application/vnd.rn-realmedia;audio/x-real-audio;audio/x-pn-realaudio;application/x-flac;audio/x-flac;application/x-shockwave-flash;misc/ultravox;audio/vnd.rn-realaudio;audio/x-pn-aiff;audio/x-pn-au;audio/x-pn-wav;audio/x-pn-windows-acm;image/vnd.rn-realpix;video/vnd.rn-realvideo;audio/x-pn-realaudio-plugin;application/x-extension-mp4;audio/mp4;video/mp4;video/mp4v-es;x-content/video-vcd;x-content/video-svcd;x-content/video-dvd;x-content/audio-cdda;x-content/audio-player;video/x-flv;application/xspf+xml;
X-KDE-Protocols=ftp,http,https,mms,rtmp,rtsp,sftp,smb

Log out and in again. You should be able to set it as default.

Source: http://ubuntuforums.org/showthread.php?t=1878236

share|improve this answer
    
I don't want set a default player for each format. I'd like to set it as a general default. –  JavaJens Nov 27 '12 at 6:35
    
I think the mplayer.desktop I've created was missing something. In general it looked like this one, but differed in such that yours worked. Thanks alot! –  JavaJens Nov 27 '12 at 17:16
add comment

go into system settings -> details -> default applications and set up your default applications as needed, in this case, video -> mplayer

share|improve this answer
    
I have the same problem on 12.04 with thunderbird not showing up as an option for calendar application, any ideas how to include it on the list? –  taneli Nov 27 '12 at 6:13
    
I guess I didn't make myself clear enough, mplayer is not listed in the detailed default applications. Hence my question. Any other ideas? –  JavaJens Nov 27 '12 at 6:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.