Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello and thank you in advance...

I have Apache2 running on Ubuntu 12.04. I am using a Netgear router, the Ubuntu box is in the DMZ though I have tried this with port forwarding as well. I contacted my ISP and they assured me that port 80 is not blocked.

When I connect to the box from a browser from within my network I get the "It works" page. However, when I try to connect from outside my network, I get a blank page.

I assume this has something to do with the apache2.conf file, but my inexperience with Ubuntu/Apache is not helping me solve this issue.

Thank you for your help and patience with a newbie...

dp

root@acmeserver:/etc/apache2/sites-available# netstat -tlpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      963/mysqld      
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1045/apache2    
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      886/sshd        
tcp6       0      0 :::22                   :::*                    LISTEN      886/sshd  
share|improve this question
    
what ip are you using when accessing from the outside? the external IP? –  Sam Nov 26 '12 at 20:32
    
Yes. the external IP I got from whatismyip.com. –  dpbklyn Nov 26 '12 at 20:32
    
i believe that apache should be able to respond to external request by default w/o any extra config. can you verify that ubuntu's frewall is disabled (it is by default) with "sudo ufw status" –  Sam Nov 26 '12 at 20:37
    
you can also verify if your port 80 is correctly forwarded by testing your port 80 from this site: whatsmyip.org/port-scanner , if it says "closed" we might start troubleshooting from there –  Sam Nov 26 '12 at 20:39
    
The firewall is inactive (this is a brand new Ubuntu installation) and Port 80 is open. –  dpbklyn Nov 26 '12 at 20:43
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.