Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My / partition is unreadable from the hard drive install, but I just ran fsck on it and know it's clean. I can open it in Nautilus from the LiveCD but chrooting to it doesn't work! It [the chrooted install] gives me errors when I try to run dpkg or apt-get. What's going on? Why can't Ubuntu start if the partition is fine? I re-installed GRUB using boot-repair (sourceforge site) and now it doesn't drop me to rescue prompt, but when I start Ubuntu it loads the kernel and initial ramdisk but can't seem to access its own disk. Is there any command line wizardry I can run from the rescue prompt? What's going on?

More information:

Recovery Mode results:

Trying to run chkdsk results in an error: Mountall: Disconnected from Upstart

Trying to drop to root shell results in an error: sulogin: cannot open user password database

"System Config" results are fine but it tells me under APT that "Database is consistent: no (BAD)". This is worrying.

The root partition is reported as having 0.05% noncontiguous space, so there are no fragmentation problems.

Something possibly unrelated is in the wall of text that appears whenever you boot without quiet splash, I saw something along the lines of "sdhci-pci 0:00:02 invalid iomem size - you may experience problems. (I don't know what this is, but it scares me!)

I ran boot-repair twice; once to get GRUB working and not drop me to rescue prompt and another time to try to purge and re-install grub. It wanted me to chroot to my old install and then run dpkg-reconfigure to uninstall and reinstall GRUB, but upon trying to run the uninstall command it told me that the command was not installed (will post screens when I find the flash drive I saw them on).

Here's my current bootinfo (generated by boot-repair). sdc is a flash drive that I had plugged in (and subsequently lost -_-), I didn't know it would be picked up by the script. This is a bootconfig summary from an hour earlier.

(I'll post screenshots when I get my flash drive.)

share|improve this question
You should post the errors you are getting. Without them it is difficult to guess what is really happening. Tip: use pastebinit or – Salem Nov 26 '12 at 15:48
I got all of those (errors) already on and screenshots besides, but I just want to know if there are any general things I might be missing. – WindowsEscapist Nov 26 '12 at 15:51
will post all information in a couple hours when i get back – WindowsEscapist Nov 26 '12 at 15:57
I would guess this is a problem with GRUB (maybe the partition specified in the boot entry is wrong, or the UUID of it). So if you can, check the content of /boot/grub/grub.cfg and see if everything is right. – Salem Nov 26 '12 at 16:05
You say your system can't access the disk after loading the kernel. Don't you get any error there (like can't mount device) or are dropped to busybox? – Salem Nov 27 '12 at 14:44
up vote 1 down vote accepted

Well, I'm going to mark this (what I did) as the answer, although if someone comes along with a detailed guide of how to diagnose early-stage kernel problems they will certainly get accepted answer and an upvote!

In 12.10, there is a (apparently at least) new feature. When Ubiquity detects 12.10 (and/or another install, but not more than 3 OSes in total including 12.10) it gives three options: "Reinstall 12.10" (keeps documents and settings and tries to keep programs), "Replace/Erase 12.10" (not actual title text) (wipes your 12.10 partition), and "Erase everything (new partition table, etc.). I tried the reinstall option and it was able to get a working Ubuntu install back again. However, it broke my mouse support, so I did some partition copying and shrinking and a complete reinstall.

TL:DR Everything's fixed now, although I still don't know what caused the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.