Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed 12.10 with the proprietary Radeon drivers and am spanning a desktop across three monitors:

$ dpkg -l fg* 
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name             Version       Architecture  Description
+++-================-=============-=============-======================================
ii  fglrx            2:9.000-0ubun amd64         Video driver for the AMD graphics acce
ii  fglrx-amdcccle   2:9.000-0ubun amd64         Catalyst Control Center for the AMD gr
un  fglrx-amdcccle-u <none>                      (no description available)
un  fglrx-control    <none>                      (no description available)
un  fglrx-control-qt <none>                      (no description available)
ii  fglrx-dev        2:9.000-0ubun amd64         Video driver for the AMD graphics acce
un  fglrx-driver     <none>                      (no description available)
un  fglrx-driver-dev <none>                      (no description available)
un  fglrx-glx        <none>                      (no description available)
un  fglrx-kernel-sou <none>                      (no description available)
un  fglrx-modaliases <none>                      (no description available)
un  fglrx-updates    <none>                      (no description available)
un  fglrx-updates-de <none>                      (no description available)

$ cat /etc/X11/xorg.conf
Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "0-DFP2"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1920x1080"
    Option      "TargetRefresh" "60"
    Option      "Position" "3840 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Monitor"
    Identifier   "0-DFP4"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1920x1080"
    Option      "TargetRefresh" "60"
    Option      "Position" "1920 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Monitor"
    Identifier   "0-DFP3"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1920x1080"
    Option      "TargetRefresh" "60"
    Option      "Position" "0 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    Option      "Monitor-DFP2" "0-DFP2"
    Option      "Monitor-DFP4" "0-DFP4"
    Option      "Monitor-DFP3" "0-DFP3"
    BusID       "PCI:2:0:0"
EndSection

Section "Device"
    Identifier  "amdcccle-Device[2]-1"
    Driver      "fglrx"
    Option      "Monitor-DFP4" "0-DFP4"
    BusID       "PCI:2:0:0"
    Screen      1
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Virtual   5760 1920
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "amdcccle-Screen[2]-1"
    Device     "amdcccle-Device[2]-1"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Everything works reasonably well, but animations (window maximize/minimize/close/etc) are very slow to the point of making the UI painful to use. What settings should I tweak to fix this?

Thanks!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.