Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a presentation with a video in it (.ogg). While it works really well on my regular desktop (Unity), on my 4-years old laptop with Lubuntu installed LibreOffice cannot play the video, it just stays white. However, I can still play the file in GNOME MPlayer.

Any idea on the codec I need to install or something?

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

It appears that openjdk doesn't support the JMF, which is required in order to play videos. This following script from here installs sun's java and fixes the problem.

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer
share|improve this answer
add comment

Sorry this may not be answer ,I do not see the comment option. I want to ask you have you tried VLC media Player VLC can play almost all Formats for you even if you have a slow pc.

Type this in Terminal

sudo apt-get install vlc
share|improve this answer
    
New users often cannot comment on questions, that's normal. I have vlc installed though, but it doesn't make a difference, because I can already play it in GNOME MPlayer, so the support is already there. –  pythonm Nov 26 '12 at 13:15
    
You said it cannot play the video and then you are saying every thing works. Is the problem already solved? –  DjBmNukez Nov 26 '12 at 13:19
    
I can play, libreoffice can't –  pythonm Nov 26 '12 at 13:21
    
have you tried Openoffice? –  DjBmNukez Nov 27 '12 at 13:08
add comment

I had the same problem recently after switching to Xubuntu 13.04. I could embed video but the frame appeared with "sound icon" (instead of question mark which appears on embedded videos) and gray frame appeared in presentation mode. Installing Oracle JRE did not help.

I am not sure what exactly helped in my case though I am quite sure the problem was GStreamer-related, probably due to some old configuration in my home directory.

Try removing ~/.gstreamer-0.10 directory (if it is present).

Or try installing gstreamer-0.10-gconf or gconf-defaults-service – I doubt this actually helped problem, but there may be some obsolete settings which get fixed this way.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.