Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So here's the problem, every time I try to install a package, I receive an error that says:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libqt4-test : Breaks: libqt4-test:i386 (!= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.2 is to be installed
 libqt4-test:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.2) but 4:4.8.1-0ubuntu4.3 is to be installed
                    Breaks: libqt4-test (!= 4:4.8.1-0ubuntu4.2) but 4:4.8.1-0ubuntu4.3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Then, when I call sudo apt-get -f install, I receive this error:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 43 not upgraded.
2 not fully installed or removed.
Need to get 0 B/61.7 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing libqt4-test:i386 (--configure):
 libqt4-test:i386 4:4.8.1-0ubuntu4.2 cannot be configured because libqt4-test:amd64 is in a different version (4:4.8.1-0ubuntu4.3)
dpkg: error processing libqt4-test (--configure):
 libqt4-test:amd64 4:4.8.1-0ubuntu4.3 cannot be configured because libqt4-test:i386 is in a different version (4:4.8.1-0ubuntu4.2)
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Does anyone have any ideas as to how I might find my way out of this dilemma?

share|improve this question
Did you add a ppa to the Software sources? It might be breaking your apt system. Disable ppa's one by one starting from the last one added running sudo apt-get update after each change. – To Do Nov 26 '12 at 13:29
@ToDo only Chrome and Google Talk... and Could that be it ? UPDATE: Tried disabling those, didn't solve the problem. – João Pinto Jerónimo Nov 26 '12 at 14:52
up vote 2 down vote accepted

Looks like multi-arch skew. Apt can see version 4:4.8.1-0ubuntu4.2 for i386 and 4:4.8.1-0ubuntu4.3 for amd64, but it needs the same version for both architectures.

Maybe you updated at a really bad time, when this package had built for amd64 but not i836 yet?

4:4.8.1-0ubuntu4.3 has built for both of them, so so you should be able to do an apt-get update followed by an apt-get -f install.

Solution: dpkg --force-depends --remove libqt4-test libqt4-test:i386 to remove both of them, then re-install them with apt-get -f install libqt4-test libqt4-test:i386

share|improve this answer
I have tried that, still get a similar message than the second snipped I posted. – João Pinto Jerónimo Nov 30 '12 at 15:45
What's the output of apt-cache policy libqt4-test libqt4-test:i386? – tumbleweed Nov 30 '12 at 20:55
apt-get -f install libqt4-test:i386=4:4.8.1-0ubuntu4.3 ? – tumbleweed Dec 3 '12 at 12:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.