Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install the newest Skype version (4.1) on my Linux.

I have downloaded the skype-ubuntu-lucid_4.1.0.20-1_i386.deb package from the official Skype site.

I removed all installed versions including the configuration files.

Now when I try to install the downloaded package, I get the following errors:

Unpacking skype:i386 (from skype-debian_4.1.0.20-1_i386.deb) ...
dpkg: dependency problems prevent configuration of skype:i386:
 skype:i386 depends on libqt4-network (>= 4:4.8.0); however:
  Version of libqt4-network:i386 on system is 4:4.7.4-0ubuntu8.2.
 skype:i386 depends on libqtgui4 (>= 4:4.8.0); however:
  Version of libqtgui4:i386 on system is 4:4.7.4-0ubuntu8.2.
 skype:i386 depends on libqtwebkit4 (>= 2.1.0~2011week13); however:
dpkg: error processing skype:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 skype:i386

Now I thought: I can install the missing dependencies manually, but trying this I got dependency errors again. It seems that dependencies of a package are not downloaded and installed automatically.

Is there a command option for dpkg so that missing dependencies are installed automatically?

share|improve this question

closed as off topic by Tachyons, Flimm, Basharat Sialvi, Eric Carvalho, Kevin Bowen Apr 14 '13 at 0:37

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Which version of Ubuntu are you using? –  To Do Nov 26 '12 at 14:07
    
I've installed "Linux Mint 12 Lisa", which is upgraded to Mint 13. –  MrPink Nov 26 '12 at 14:47
    
Ok Micha, but "Linux Mint" is not an official Ubuntu distribution...but I think, if you are running "Mint 13" the skype package would be for "precise" not for "Lucid".Package for (ubuntu 12.04 multicarch). then you should install it with gdebi. –  Roman Raguet Nov 26 '12 at 15:07
    
Ok, I also tried this but still get: Unpacking skype:i386 (from skype-ubuntu-precise_4.1.0.20-1_i386.deb) ... dpkg: dependency problems prevent configuration of skype:i386: skype:i386 depends on libqt4-network (>= 4:4.8.0); however: Version of libqt4-network:i386 on system is 4:4.7.4-0ubuntu8.2. skype:i386 depends on libqtgui4 (>= 4:4.8.0); however: Version of libqtgui4:i386 on system is 4:4.7.4-0ubuntu8.2. skype:i386 depends on libqtwebkit4 (>= 2.2~2011week36); however: dpkg: error processing skype:i386 (--install): dependency problems - leaving unconfigured –  MrPink Nov 26 '12 at 15:15
    
.. the skype version from within the package manager can be installed without problems, but it is the version 2.* which i don't want. ;( –  MrPink Nov 26 '12 at 15:16

2 Answers 2

Well, as far I as know, dpkg can not resolve dependencies, but because you have Ubuntu Lucid 10.04 installed , you can use "Gdebi" *(gui tool and resolve dependencies)*just doble click in the .deb package.

Another options is... you can run sudo dpkg -i package.deb (it will not a complete install with error dependencies).
After that you just run sudo apt-get -f install and the apt-get tool will correct the missing dependencies.

Hope this will useful!.

share|improve this answer
    
Ok I will try Gdebi. The problem with sudo apt-get -f install is, that it recognizes that there is a broken package (skype) but instead of installing the missing dependencies it wants to delete the broken package. –  MrPink Nov 26 '12 at 11:28
    
Ok Micha, you can try another option and is sudo dpkg -i package.deb and then go to the sypactic tool and in the menu, and use Edit > Fix broken packages. –  Roman Raguet Nov 26 '12 at 11:39
    
I tried, but it's the same like executing sudo apt-get -f install the package manager wants to remove skype instead of install necessary dependencies. –  MrPink Nov 26 '12 at 12:42

If you are using 64-Bit Linux, then this problem is usually due to missing libraries.
Go to Ubuntu Software Center and install ia32-libs package, and then reinstall Skype.Hope it will solve your problem.

share|improve this answer
    
The Software Manager says that ia32-libs is already installed. –  MrPink Nov 26 '12 at 12:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.