Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All the videos on youtube are flickering on my Ubuntu.

See screenshot: http://imgur.com/51dAk

This happens with HTML5 enabled and disabled.

I am running Ubuntu 12.10 on a Thinkpad X61s.

This only happens on Google Chrome.

share|improve this question
    
I can confirm this. –  Frantique Nov 29 '12 at 10:50

3 Answers 3

up vote 1 down vote accepted

This seems to be a known bug:
http://code.google.com/p/chromium/issues/detail?id=124569

A workaround that did it for me, was starting chrome with this command line parameter:
--disable-accelerated-compositing

share|improve this answer
    
your 'edited' (==completely replaced) answer now does work for me. please consider adding another answer instead of 'editing' (replacing the old one) next time. thx –  törzsmókus Mar 15 '13 at 9:19
    
but anyway, thanks for the workaround and the bug link –  törzsmókus Mar 15 '13 at 9:21

The problem seems to be with the hardware rendering: I noticed this behaviour when I enabled the flag “Override Software Rendering List”, i.e. enabling GPU acceleration on unsupported hardware.

Have a look at chrome://flags whether it is enabled for you as well.

(I have an Intel GMA X3100 graphics card in a Thinkpad x61-7673.)

share|improve this answer
    
Thanks for this hint. Unfortunately I did not enable this flag. Also enabling or disabling any other flag regarding the GPU does not have any affect on this problem. –  lukassteiner Jan 19 '13 at 17:11
    
after the upgrade from Chrome 23 to 24, I’m also facing this problem regardless of my flags! but before the upgrade, it used to depend on that. –  törzsmókus Jan 20 '13 at 18:05
    
please comment here if you find a relevant bug report in the Chromium issue tracker THX –  törzsmókus Jan 20 '13 at 18:07
    
or you may as well file one :) –  törzsmókus Jan 20 '13 at 18:20
    
for the record, the workaround --disable-accelerated-compositing works for me. I must have missed the relevant issue in the other answer. –  törzsmókus Mar 15 '13 at 9:17

I recently started having trouble with Chrome's video (Mar/Apr 2013, Ubuntu 12.10), but only in YouTube. The sound was still ok, and other sites were fine.

I found similar problems reported on Windows Chrome and loosely followed their instructions to disable the PepperFlash pugin. This has improved things massively. Try:

about:plugins
  • click +
  • click disable by the /opt/google/chrome/PepperFlash/libpepflashplayer.so entry.

(Maybe this entry could be improved slightly?) (The PC mag article I found the answer in said something about Google monitoring.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.