Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some weird reason language settings have gone awry and the OS language changed for some random reason from English to Chinese/Japanese. (I do not have a slightest idea why; keyboard is Finnish/Scandinavic.)

Any help concerning how to switch the language setting back to English much appreciated!

share|improve this question
1  
When you enter a text console Ctrl+Alt+F1 and log in, type echo $LANG, what does it say? You can return to the GUI by Ctrl+Alt+F7 –  jippie Nov 26 '12 at 7:41
add comment

1 Answer

Something I did caused this same behavior. In my case, I think I did it to myself because I was actually doing things to the language and keyboard settings. Fortunately, the menu items seem to come up in a combination of English and Chinese, so I was able to find the tool I needed. First, read this:

Install/Remove Language show only English, no other choice

Note the positions of the controls in the dialog. They will be labeled in whatever language you have set, but they will be in the same place. You have to drag "English" or any other language you want to the top of the list. Then click the "Apply System-Wide" button. You will be prompted for your password.

What I can't figure out is why I had Chinese localizations installed in the first place.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.