Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have a Kingston DataTraveler SE6 8GB USB stick which I use as a liveusb medium. The liveusb was created with UNetbootin and was working fine, I also enabled persistance in it.

Today I connected the USB into another computer but it was not being mounted anywhere. I opened a terminal window and issued lsusb and it gets detected:

  • Bus 001 Device 016: ID 0951:1664 Kingston Technology

And opening the Discs application shows this:


It says it's located in /dev/sdd however that location is non existant, this is what I get from blkid:

 /dev/sda: LABEL="Backup 2" UUID="6C5D28267DB27322" TYPE="ntfs" 
 /dev/sdb1: LABEL="Reservado para el sistema" UUID="4C4C42384C421CD8" TYPE="ntfs" 
 /dev/sdb2: UUID="D8E444D2E444B512" TYPE="ntfs" 
 /dev/sdc1: LABEL="Backup" UUID="6ECB255D7EC7EAD4" TYPE="ntfs" 
 /dev/sdc2: UUID="c7a99999-898f-4452-afc2-05525c6b20f2" TYPE="ext4" 
 /dev/sdc3: UUID="A5EC-08D2" TYPE="vfat" 
 /dev/sdc4: UUID="00b3c665-7957-4884-8244-e7f94b2a12b5" TYPE="swap" 
 /dev/sdc5: UUID="efe13c6c-c69d-4b91-9a7d-a33c21ec3fb0" UUID_SUB="478d3690-c14c-4dec-ac7c-06a7daad021d" TYPE="btrfs" 
 /dev/sdc6: UUID="79e19479-3d06-4e0f-a8a5-352a0dc71deb" UUID_SUB="5dc9e118-a6e2-4e1f-bb08-d103608d6afc" TYPE="btrfs" 

Since the USB stick is getting detected I'm hoping there's still something I can do to format it and keep using it, How can I forcefully mount it and format it to FAT?

If I attempt to mount it it gives me this:

 sudo mkdir /media/usbdrive
 sudo mount -t vfat /dev/sdd /media/usbdrive
 mount: special device /dev/sdd does not exist

If I try to use the command dd this happens:

 sudo dd if=/dev/zero of=/dev/sdd bs=512 count=1
 dd: opening `/dev/sdd': No medium found

If I try to use mkfs.vfat this happens:

  sudo mkfs.vfat /dev/sdd
  mkfs.vfat 3.0.13 (30 Jun 2012)
 /dev/sdd: No medium found

It is worth mentioning that, in both Ubuntu and Windows the USB is detected but can't be mounted. Windows makes a sound notifying that a device has been inserted and Ubuntu does as described above. Under Windows the device is assigned a drive letter in my case E: however it doesn't show up in the Explorer sidebar but does show up under the Device Manager.

share|improve this question
Are you sure that ntfs-3g is installed on that new machine? if not.. terminal sudo apt-get install ntfs-3g if the driver is installed, what happens when you do this? sudo mkdir /media/usbdrive sudo mount -t ntfs /dev/sdd /media/usbdrive – superunamused Nov 26 '12 at 2:03

4 Answers 4

up vote 1 down vote accepted

The problem is most likely the partition table written by the manufacturer. Have a look at the answer on this question and see if it helps you.

share|improve this answer
Well this is over my head now, dd: opening /dev/sdd: No medium found . It's there but it's not there. – Uri Herrera Nov 26 '12 at 9:43
Unplug the device and plug it back in again. Make sure that it is the only device on a USB 2.0 bus. Don't use a USB 3.0 bus if you have one. Maybe try it on a different machine completely. Double check the device name with blkid and try again. If it still doesn't work, then I guess that sometimes a dead thumb drive is just a dead thumbdrive. – fabricator4 Nov 26 '12 at 19:47
I guess it is dead after all, too bad. – Uri Herrera Nov 29 '12 at 4:10
I had the same issue and I also think my pendrive is dead. It was working on my car usb player and then my baby decided to touch it and it stopped working in the sound system. I thought I would just have to reformat it and copy the mp3's back to it but I got this message and strongly believe it's dead now... I'll have to buy another one :( – rosenfeld Jul 28 '14 at 17:35

I have had exactly the same problem : a 8GB pendrive working like a charm or not mounting depending on the computer and on the usb port. I fund that this 8GB pendrive had a max current of 500 mA (5 times more than my other pendrives)! I am convinced it is the source of the problem.

Note : I fund the max power of the device with :

sudo lsusb -D /dev/bus/usb/xxx/yyy

where xxx and yyy are given by lsusb.


share|improve this answer

I had similar problem (with external HDD). I solved it in this way, that I inserted cable to other USB port. I supposed that tis one, which didn't work was USB3 and second was USB2.

share|improve this answer

I had the same problem.

Adata 32GB C902.

Everywhere I tried to open the drive I gettin' the message: "Medium not found."
The drive was listed in lsusb (Linux) and "Please insert disk in drive X" in (Windows)

I booted my windows XP partition and navigated to this site: Adata USB Recovery
I typed the serial number of the drive, waited few seconds and the download started.

The adata recovery tool says:
4-5 lines of metadata including Wrong device name starting with XXXXXXX end etc.
Firmware Ver.N : NO FIRMWARE
I pressed update and it started repairing the drive ~2min and everything was OK.
I unplug the device and plug it again - I have now 30GB free space.

Just before ~5 min I was fixed it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.