Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having problems getting grub to load Windows 8 properly after installing Ubuntu 12.10 and Windows 8 on a solid state drive. Here's what I did:

  1. Fresh install of Windows 8 using USB recovery drive (partitioned SSD for UEFI) -- Tested windows install and it worked fine
  2. Built bootable USB with Ubuntu 12.10 64bit and installed Ubuntu -- Used Ubuntu's installer to partition the Windows 8 partition and install there
  3. Reboot - try to load windows 8 from grub -- Ubuntu loads correctly; windows load reports various problems with permissions and not being able to find files - I'll update what the actual errors are
  4. Tried to fix the boot problem using boot-repair: -- here's the output: http://paste.ubuntu.com/1384522/

So, this is my first time trying to setup a dual boot system and I think that UEFI is the main culprit in getting this to work correctly. What do I need to

share|improve this question

marked as duplicate by Eric Carvalho, Thomas W., Radu Rădeanu, Mitch, aquaherd Jun 23 '13 at 22:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
It looks like you may have to many partitions for MBR to handle, I ran into this while using bootcamp on my Mac. Do you ever see the windows boot logo? –  David Nov 26 '12 at 0:54
    
David, the system is UEFI so the MBR is not used. And the disk is GPT so the partition limit is above 124. –  LovinBuntu Nov 26 '12 at 13:18

2 Answers 2

  1. Use a Windows disc this way: https://help.ubuntu.com/community/RestoreUbuntu/XP/Vista/7Bootloader , until you get access to Windows
  2. If the GRUB menu has disappeared, you can recover it via Boot-Repair
share|improve this answer

This problem is identical to this one, aside from some minor differences in partitioning. (Your EFI System Partition, or ESP, is on /dev/sda2, vs. /dev/sda7 for the posted-to question, which affects the partition number in the GRUB 40_custom entry.)

share|improve this answer
    
Thanks. I think I had multiple problems. I followed the answer from the above post and changed the /etc/grub.d/40_custom entry to '/dev/sda2'. After that, when I tried to boot Windows, I got a permission error. I went into the BIOS and turned secure boot off. I don't know how to get grub2 to boot windows with secure boot, but this solution works good enough for me. –  kingtri Nov 29 '12 at 4:30
    
If Ubuntu's GRUB is booting Ubuntu with Secure Boot enabled but not booting Windows 8 with Secure Boot enabled, then that sounds like a bug in GRUB or in the Shim loader that launches it. I recommend filing a bug report (as described at ubuntu.com/community/report-problem). –  Rod Smith Nov 29 '12 at 20:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.