Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As you can see by the very long title, that's exactly what happened. After I proceeded to install Ubuntu (12.04 LTS) to my computer, making it run alongside Windows 7, I got a black screen asking me to remove the cd, close the disk tray, and press enter. Now I m back in Windows. Any help?

share|improve this question
add comment

3 Answers

This problem can be solved in the following way

  1. once prompted to remove dvd and close the tray and press enter, do it without any delay.
  2. now your system starts with windows automatically, if not you start your system.
  3. wait for all windows services to start.
  4. now go to startup folder, you will find wubi there.
  5. click on it and follow the instructions ubuntu gets installed.
share|improve this answer
add comment

Try holding Shift during boot-up.

If that doesn't work, then the GRUB bootloader is not installed.

You'll need to reboot into the Live CD, open up the Terminal (CTRL - ALT - T) and type the following commands:

sudo grub-install /dev/sda
sudo update-grub2 /dev/sda

If you run those commands successfully, and you're still booting straight into Windows, then reboot again and hold Shift while it's starting up.

share|improve this answer
add comment

I don't know if this will solve your problem, but give it a try.

In Windows, right-click Computer and go to System Properties->A*dvanced System Settings*.

Then go to Startup and Recovery. Check the Time to display list of operating systems if not checked, and give it the number of desired seconds (30, for example). Just in case, set the Default Operating System to Ubuntu.

NOTE: The above steps are for Windows 7. It may vary for other versions.

share|improve this answer
    
This will help only if Windows bootloader is installed, which is not the case after Ubuntu installation. –  Andrejs Cainikovs Apr 22 '13 at 22:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.