Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The GWT Desinger is not working on Ubuntu 12.10. It worked on Ubuntu 12.04. I installed the Eclipse Plugin as described on the GWT Homepate If I want to open the Design-View (for an xml-GWT-File), Eclipse crashes (prompt closing of the application).

I found this two workarounds for which are for 12.04 (but on 12.04 i did not need this to get it working - it worked out of the box for me). I tried them on my 12.10 Ubuntu but they are not working. But I have to say that I can't find the "Use WebKit for rendering GWT UI (if available)"-Flag.

What can I do to get the GWT Designer working? I tested it successfully again on a 12.04 Ubuntu VMware image. If I don't get a solution, I have to downgrade my Ubuntu to 12.04 again.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I found a solution that works (but only with Eclipse 3.7.2):

Download Eclipse Classic 3.7.2.

Install GWT Designer via Plugin-Link in Eclipse as described here.

Install the GWT SDK (and the rest) via Plugin-Link in Eclipse as described here

Execute Workaround 2 from this page.


You can find more information about this issue in this bug.

share|improve this answer
add comment

Installing these packages worked for me in Ubuntu 12.04 (64bits) with STS 2.9.2 based on Eclipse 3.7.2:

sudo apt-get install libicu48
sudo apt-get install libwebkitgtk-1.0-common
sudo apt-get install libwebkitgtk-1.0-0

Inspired by http://elgali.net/2012/05/14/gwt-designer-eclipse-plugin-in-ubuntu-12-04/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.