Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Both the Wifi and the ethernet connection to the internet are not working. All had been functioning fine until the Ubuntu suspended itself. On re-starting, the connection to internet failed to function and now I get the message "Network Disabled" whenever I re-boot.

nm-tool tells me the state is "asleep". Stopping and starting the NetworkManager has no effect

The machine is an Inspiron 9300 and work perfectly with Windows. How do I wake the networking up?


share|improve this question

Ahh, the good old NM bug.

stop network-manager

sudo rm /var/lib/NetworkManager/NetworkManager.state

start network-manager

Scream bloody murder if this fixes the issue. (This really should have been fixed a long time ago)

share|improve this answer
Thank you. Worked a treat. I wasted quit a few hours on this one and almost considered going back to Windows. – Terry Dixon Nov 25 '12 at 23:36
I've just encountered this one with Ubuntu 13.10, and these instructions fixed it for me. thumbsup (I had also manually forced it back up with ifconfig eth0 up and dhclient eth0, but of course that's not the right way as it bypasses all the management.) – Jonathan Gilbert Nov 12 '13 at 4:14
This problem is still present in Ubuntu 14.04 - and your answer worked just fine. Thanks. – noumenon Nov 19 '14 at 10:58
Thanks! I skipped the second command (sudo rm /var/lib...) and it still solved the issue for my Ubuntu 14.04.1 LTS on VMWare. – Isaac Feb 28 '15 at 12:50
This fixed it for me! Wow! Thanks! – kirbyfan64sos Apr 19 '15 at 23:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.