Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this question has been asked before, and I know I've fixed this before, but I can't find anything that works for some reason.

Background: Every time I log in, my resolution resets to 1024x768, so I have to open up the nvidia settings and change it back to 1280x1024 every time.

Question: Is there a fix for this issue?

Additional Info:

  • Dell XPS 400
  • Xubuntu 12.10 (fresh install, not upgraded from 12.04)
  • Graphics Card: Nvidia GT430
  • GPU Driver: nvidia-current-updates
share|improve this question
add comment

3 Answers 3

nvidia-settings

In nvidia-settings, under X Server Display Configuration, click Save to X Configuration File. If you've never done this before, it will complain about not being able to parse /etc/X11/xorg.conf. Just tell it "OK", it doesn't matter. You'll need to give it your password to elevate so that it can write to that file. Once you've done this, your resolution (and other changes in nvidia-settings) will persist through reboots.

share|improve this answer
    
I thought I had tried that before but just to be sure, I deleted the old xorg.conf, applied my settings, then saved a new one. This, unfortunately, didn't work. I feel weird doing this, but I'm answering the question myself since I figured out how to do it, and accepting it tomorrow. Thanks for responding! –  DaimyoKirby Nov 26 '12 at 21:10
add comment
up vote 0 down vote accepted

The problem I think I was hitting was that the Nvidia x-server would load my preferred resolution (1280x1024), but then the settings manager would load its preferred option, which by default was 1024x768.

How I ended up solving this - in terminal:

  • sudo leafpad /etc/X11/xorg.conf

Scroll down, likely near or at the bottom, to where it says something like:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "1280x1024_75 +0+0; nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

The third option ("metamodes") is the resolution option. In that line, I removed the ; nvidia-auto-select +0+0. The line now looked like this:

Option         "metamodes" "1280x1024_75 +0+0"

This disallowed the settings manager to select the resolution it wanted and override xorg.conf, thus forcing the computer to use 1280x1024 by default.

share|improve this answer
add comment

My setting were going from 1200x790 to a default of 640x480.

Here's the solution I found.

share|improve this answer
1  
Welcome to Ask Ubuntu! The thread you linked is a bit long. Could you edit your answer and provide the specific steps that you took to resolve the issue and using the link only as a reference? –  Kevin Bowen Aug 29 '13 at 7:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.