Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I installed ubuntu, everything was working perfectly except for the wireless networks. When i click on networks wireless is not an option. I know my wireless works because it worked fine before on fedora and windows. Can anyone help me?

share|improve this question
    
Start by typeing lspci | grep Ethernet and edit your question with the results. If this command gives no results try a plain lspci and locate the wifi adapter model. –  To Do Nov 25 '12 at 21:18
    
Here are the results "03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)" –  Joel Hunt Nov 25 '12 at 21:24
    
That's the cable network connection not the wifi. Try lspci again and fetch the wireless card type. –  To Do Nov 25 '12 at 21:30
    
Is this it? "03:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)" –  Joel Hunt Nov 25 '12 at 21:40

1 Answer 1

up vote 0 down vote accepted
  1. Open Update Manager
  2. Open Settings
  3. Go the the Additional drivers tab.
  4. Check if a Broadcom proprietary driver is offered. Install it.
  5. Reboot.

If that doesn't work, try following these instructions.

In short:

  1. Identify your card by typing in a terminal lspci -vvnn | grep 14e4
  2. Check which driver is suitable for you from this list
  3. In your case (BCM4318) you need the b43 driver
  4. Open a terminal (Ctrl + Alt + T) and run sudo apt-get update followed by sudo apt-get install firmware-b43-installer
  5. Reboot.
share|improve this answer
    
It will not let me apply the changes do i have to be logged in as root? –  Joel Hunt Nov 25 '12 at 22:01
    
Didn't it simply ask you for the sudo password? –  To Do Nov 25 '12 at 22:02
    
It did not ask me. However it did show one driver which is identified as Unkonwn with do not use checked and when i check Continue using as a manuel driver (the only avalible option that is clickable) it higlights red. –  Joel Hunt Nov 25 '12 at 22:04
    
I would try the instructions in the link in my answer above installing the b43 driver. –  To Do Nov 25 '12 at 22:06
    
Thank you sir It worked with the other instructions –  Joel Hunt Nov 25 '12 at 22:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.