Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently accidentally deleted my Ubuntu partition. When I rebooted the computer, I got the dreaded grub rescue> prompt. I thought, "simple fix, boot an ubuntu CD and add a new MBR". However, my BIOS will somehow not let me access any menus with any keys specified by my PC manufacturer (MSI). I think this is something to do with a fast boot mode or something, because I don't see a MSI logo on boot, so it may be skipping POST.

I need a way to boot an Ubuntu LiveCD from grub or to boot the Windows partition. Nothing I have tried have worked. I tried listing the contents of all the drives provided by "ls", but GRUB can't read any of them.

share|improve this question
    
Did you try the del key, immediately on powerup? –  To Do Nov 25 '12 at 21:21
    
Yes, many times. I tried loads of keys. Holding, mashing, single press, nothing worked. –  ranmat11 Nov 25 '12 at 21:39
    
Worst case scenario, I may have to buy a USB hdd enclosure and replace the MBR with another computer. –  ranmat11 Nov 25 '12 at 22:06
1  
When I had a Windows XP disk in the drive but did not press anything, it would find the Windows installation. –  queueoverflow Nov 26 '12 at 13:18
add comment

1 Answer 1

There are different combinations on different BIOS versions:

  • AMI [DEL]-Key after boot
  • Award [CTRL][ALT][ESC] or [DEL].
  • Phoenix [CTRL][ALT][ESC] or [CTRL][ALT][S] or [CTRL][ALT][Insert]
  • Or [F2]

Maybe you try these combinations to start your bios.

share|improve this answer
    
I'm not seeing any MSI logo or BIOS info prompt on startup; as I said maybe it is locked into some strange fast boot that doesn't check for keypresses properly? I tried you suggestions and many more. –  ranmat11 Nov 26 '12 at 18:31
    
Maybe I should open it up and remove the CMOS battery for a bit; would that help? It would reset the BIOS settings, so maybe it would allow me in. –  ranmat11 Nov 26 '12 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.