Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the last version of Ubuntu. I tried to compile and run simple c program. I was get error:

fatal error: stdio: No such file or directory

I installed and updated gcc compiler few times, and I still get this error. Can anybody help me please? I put here the video record, there you can see my documents folder with libraries: http://screencast.com/t/Vi5b7cXnZ

share|improve this question
1  
Could you share what you are trying to compile, what you type when you compile it and what you see after in text rather then a movie? –  Nanne Nov 25 '12 at 20:53
    
Sounds like you don't have the library. Did you install build-essential? –  Larry Price Nov 25 '12 at 21:40

1 Answer 1

I looked at your video and saw the problem in your program source. The reason you are getting this error is because you are using:

#include <stdio>
#include <stdlib>

You should be using:

#include <stdio.h>
#include <stdlib.h>

..use these corrections in your program and it should now compile.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.