Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Lacie Lightscribe software on Ubuntu 12.04. Everything seems to be fine, the drive is detected, the proper media is detected, but when I click print I get the message "Printing Requires Root Privileges".

I am the main (administrator) account on this computer, part of the sudo group and I cannot seem to find an answer to this dilemna in plain english.

I've seen some apparently relevant posts which say things like "check whether the files /usr/4L/4L-gui and /usr/4L/4L-cli have any setuid-bits set. If so, remove them" but I need more detailed step-by-step instructions than that, please.

Is there anyone who knows how to solve this?

share|improve this question
Can you add links to the pertinent posts? – Jorge Castro Nov 25 '12 at 18:44
Here is a long link that is a PDF file:… another post: – James Nov 25 '12 at 21:03
Okay, apparently nobody knows the solution, or at least no one that is interested in sharing it... – James Dec 3 '12 at 1:56
Have you tried this from the Lightscribe website? – user104140 Dec 3 '12 at 8:38

You could use the SimpleLabeler application (see further below) and not the Lacie 4L lightscribe application as the former does not require root access and it works well straight away with most drives. I regularly use it and have never used gksudo or sudo.

If you want to use the Lacie 4L application, download the Lacie Labeller and the Host Software from the official site. Unfortunately, there are no .deb files available and no source code available, so you'll have to use alien to convert the rpms to debs. So run

sudo apt-get install alien

You may find it helps to rename the rpms to something like 'Lacie_Labeller' and 'Lacie_Host', as the original file names are very long; they will be renamed by alien with the version number of the software anyway. So cd to the download folder and run for each rpm:

sudo alien name_of_your_file.rpm 

Then install them individually with

sudo dpkg -i name_of_file.deb

The LaCie LightScribe Labeler for Linux package should install fine. Don't worry if you get an error such as: A later version is already installed when installing the Lightscribe system software, as you may already have some Lightscribe files installed if you have installed other Lightscribe software before.

Now, launch the Lacie application with

gksudo 4L-gui 

It is fine to do this, and the requirement for gksudo cannot be easily removed from the program without recompiling it.

The gui of lacie 4L is straightforward-you choose your template from anywhere on your drive then resize it with the program's tools. You can place text on the template beforehand with your image program. The template below is from

enter image description here

Here is my sample burn of a template from using Lacie 4L.

enter image description here


Here's how I set it up the SimpleLabeler application on Ubuntu 12.04.

The download site for the debs (also mentioned in the comments by user104140) is at First download the system software and then the Labeler application.

You must install the system software before the labeler application 'to maintain the necessary dependencies', although the version numbers of the two packages do not need to match.

You should use gdebi or software-center to install the debs and then you will find the labeler application in /opt/lightscribeApplications/SimpleLabeler.

Now cd to the folder mentioned above and launch it with ./SimpleLabeler or create a symbolic link so that you will be able to call it with just SimpleLabeler:

sudo ln -s /opt/lightscribeApplications/SimpleLabeler/SimpleLabeler /usr/local/bin

Now launch the labelling program as your normal user and select your options:

enter image description here

enter image description here

Here is the sample result:

enter image description here

share|improve this answer

There is an in-depth How To on the Ubuntu Forums located here It requires this script:


# Opens 4L-gui under sudo to print

foo=`gksudo -u root -k -m "Enter your password for 4L-gui root access (It needs it to burn the label image.)" /bin/echo "got r00t?"`

sudo 4L-gui

Follow the how to as to place it in the proper location and activate it

share|improve this answer

I had the same problem. Somehow the 4L files were set to a non-root user:group. I fixed it by executing:

sudo chown root:root /usr/bin/4L-*
sudo chown -R root:root /usr/share/4L
sudo 4L-gui
share|improve this answer
Erm, that runs the software with root privileges. The OP said he wanted a solution without needing root privileges... – Fabby Jan 18 at 17:53
I had the same problem and arrived at the same solution. If you install the .deb packages via the software center, the program files get the owner and group of the current user, not root. Then you get the requires root priviledges error even if you start the labeler with sudo/gksudo. – alexg Feb 13 at 8:23

I have used the SimpleLabeler program for many years. Given that you are installing into ubuntu 12.04, you may find the following instructions to be helpful:


share|improve this answer

In a terminal run the command

sudo nautilus

It will launch nautilus file manager as user root and then you go to the folder the Lacie Lightscribe software is installed and double click on it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.