Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an SSD with ubuntu installed, now, I'm trying to format a My Passport Essential hdd, throught GParted with no success.

I've tried to make it primary and I've tried to make it extented, GParted would say it had succeed,But I cannot act on the hdd, seems like I have no premission.

In the Properties dialog box it says

You are not the owner, so you cannot change these permissions.

I can't create any file nor folder in the hdd and I can't transfer files to the hdd.

share|improve this question
The command below has 1 variable; tell me where you mount the disc and I can make it exactly what you need. Also consider looking into adding the disc to /etc/fstab to mount it elsewhere on boot if you want. – Rinzwind Nov 25 '12 at 12:37
Also please read up on how Ubuntu works in relation to admin and users! You will encounter things like this more and more and more and it is nothing too spectaculair: Linux has a strict seperation of what a user may do and where you need to have permissions granted from a admin (like accessing hard disc space ;) ) – Rinzwind Nov 25 '12 at 12:54
up vote 2 down vote accepted

After you formatted the external disc with ROOT you need to grant priviliges to your USER for access. So drop down to a terminal with control alt f2 and navigate to the directory this disc is mounted and then give yourself permissions with:

sudo chown -R $USER:$USER {mountpoint/directory}

After that your user can read, write, remove on the disc. If you have more than 1 user and need it for more than 1 persons change the 2nd $USER to the group you need it to be.

share|improve this answer
Why not to use chown -R ? This way if there is any directory there it would also be changed – Davisein Nov 25 '12 at 13:24
Thank you!! it worked.! :) It did however work only when I used the terminal application..not the command from alt+ctrl+f2 :) – Roy Nov 25 '12 at 18:41
Oh thank you :) I did accept right now.. – Roy Nov 27 '12 at 10:25
About updating - how do I do that :)? – Roy Nov 27 '12 at 10:26
typo @roy ;) meant upvote >:) – Rinzwind Nov 27 '12 at 11:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.