Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a program which when I pin it to the launcher, pulses slowly 5 times but then does nothing. If I have a launcher on the desktop I can ask to see its properties so I can see what the actual command is.

Since the icon I have pinned doesn't work (I pin it to the launch bar, then close the program and try to fire it up again), I would like to see what command it is executing so I can figure out what is wrong.

The answer I have received is quite useful but something unusual is apparently going on with the particular file and I would like to see what the launcher command is actually doing. The command which works is

/home/ilan/Fiji.app/ImageJ-linux32

If I make a desktop icon with this command, that will launch the application. I can even copy the desktop icon to the launch bar and it will work. Here is the puzzle: if I copy the desktop icon to the launch bar, I will end up with TWO icons on the launch bar 1) the desktop icon which I copied and 2) the one which is actually running.

It is the 2nd one which I'd like to lock to launch bar, because it is what is really running. However if I close the application and click on it, it won't launch. Conclusion: it isn't giving the command

/home/ilan/Fiji.app/ImageJ-linux32

So what command IS it giving? That is what I would like to know.

This is medical software readily available on the web at http://fiji.sc/

share|improve this question
add comment

1 Answer 1

For globally installed applications, the .desktop file can be found in /usr/share/applications. For custom applications you will need to look in ~/.local/share/applications.

Nautilus seems to drop the .desktop off the filename in all view modes that I tried which is confusing. It's probably best to look at the contents of the file with cat.

Eg.:

cat /usr/share/applications/xyzprogram.desktop
share|improve this answer
    
Your answer was useful but not there yet. I did find in .local/share/applications an old version which was pointing to something which no longer exists, so I deleted the file from applications. However when I fire up the application it fails to enter a new file. Any suggestions? THanks –  Ilan Nov 25 '12 at 14:16
    
You could still have looked inside the file to see what the executable was. Try looking in /usr/share/applications –  fabricator4 Nov 25 '12 at 19:17
    
Again your answer is quite useful but not quite there. I'll write an "answer" to my question to show the problem in more detail. –  Ilan Nov 26 '12 at 5:59
    
@Ilan, To describe more about your problem, please expand the question itself, by editing it. Answers are to be added only if you have got a solution to your problem. –  saji89 Nov 26 '12 at 7:00
    
Thanks. I found the possibility of editing the problem when I tried to use the "answer". I didn't know it existed. –  Ilan Nov 26 '12 at 10:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.