Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on Ubuntu 12.04 LTS (in gnome-shell) and I am unable to use my "d" key. Regular gnome-2 works perfectly fine, but for some reason I cannot use my "d" key in gnome-3. I recently installed it and have been trying to figure this out, but I have no clue what's going on. I attempted to disable the keyboard shortcut that minimizes active windows, but that did not work. (My only option right now is to use CTRL-V to paste my "d"s.)

On top of this, my arrow keys automatically move my windows and I cannot move through text using them. What's going on here, folks?

Here's the result of that comman()

[apps/cheese]
wide-mode=false

[apps/onboard]
key-label-font='Ubuntu'
key-label-overrides=['LWIN:?:super', 'RWIN:?:super']
layout='Compact'
schema-version='1.0'
system-theme-associations={'Default': 'Ambiance', 'HighContrastInverse': 'HighContrastInverse', 'LowContrast': 'LowContrast', 'HighContrast': 'HighContrast'}
theme='/usr/share/onboard/themes/Ambiance.theme'
use-system-defaults=false
xembed-onboard=true

[apps/onboard/theme-settings]
color-scheme='/usr/share/onboard/themes/Aubergine.colors'
key-fill-gradient=8.0
key-gradient-direction=-4.0
key-label-overrides=@as []
key-size=99.0
key-stroke-gradient=32.0
key-style='gradient'
roundrect-radius=30.0

[apps/seahorse/windows/key-manager]
height=476
width=640

[apps/shotwell/preferences/ui]
display-basic-properties=true
events-sort-ascending=false
show-welcome-dialog=true
sidebar-position=228

[apps/shotwell/preferences/window]
library-height=768
library-maximize=false
library-width=1024

[apps/update-manager]
first-run=false
launch-time=1353760948
show-details=true
window-height=518
window-width=840

[ca/desrt/dconf-editor]
height=696
maximized=false
width=1387

[com/canonical/unity-2d]
average-bg-color='#e65051'

[com/canonical/unity-2d/launcher]
edge-responsiveness=0.20000000298023224
hide-mode=1
only-one-launcher=false

[com/ubuntu/update-notifier]
regular-auto-launch-interval=7
release-check-time=uint32 1353288984

[desktop/unity/dash]
home-lens-ordering=['applications.lens']

[desktop/unity/launcher]
favorite-migration='3.2.10'
favorites=['gummi.desktop', 'glchess.desktop', '/usr/share/app-install/desktop/gnumeric-common:gnumeric.desktop', 'FBReader.desktop', 'paprefs.desktop', 'fraqtive.desktop', 'xaos.desktop']

[desktop/unity/lenses/applications]
display-available-apps=false
display-recent-apps=false

[org/gnome/deja-dup]
backend='u1'
prompt-check='disabled'

[org/gnome/deja-dup/s3]
folder='$HOSTNAME'

[org/gnome/desktop/a11y/applications]
screen-keyboard-enabled=false

[org/gnome/desktop/background]
color-shading-type='solid'
picture-options='none'
picture-uri=''
primary-color='#000000000000'
secondary-color='#efef29292929'

[org/gnome/desktop/interface]
cursor-blink-time=1000
cursor-size=5
cursor-theme='DMZ-Black'
gtk-color-scheme='selected_bg_color:#aa0011;'
gtk-key-theme='Default'
toolkit-accessibility=false

[org/gnome/desktop/media-handling]
autorun-x-content-ignore=['x-content/image-dcf', 'x-content/audio-player']
autorun-x-content-open-folder=@as []
autorun-x-content-start-app=['x-content/unix-software', 'x-content/image-dcf', 'x-content/audio-player']

[org/gnome/desktop/screensaver]
embedded-keyboard-command='onboard --xid'
embedded-keyboard-enabled=true
lock-delay=uint32 0
lock-enabled=false

[org/gnome/desktop/session]
idle-delay=uint32 0

[org/gnome/desktop/wm/preferences]
button-layout=''
num-workspaces=2
visual-bell=true

[org/gnome/eog/ui]
image-gallery=false
sidebar=false
statusbar=true
toolbar=true

[org/gnome/eog/view]
background-color='#000000'
use-background-color=true

[org/gnome/evince/default]
window-ratio=(1.3725490196078431, 1.2601010101010102)

[org/gnome/file-roller/dialogs/extract]
overwrite=true
recreate-folders=true
skip-newer=false

[org/gnome/file-roller/listing]
list-mode='as-folder'
name-column-width=250
show-path=false
sort-method='name'
sort-type='ascending'

[org/gnome/file-roller/ui]
sidebar-width=200
window-height=480
window-width=600

[org/gnome/gedit/plugins]
active-plugins=['zeitgeistplugin', 'modelines', 'spell', 'docinfo', 'time', 'filebrowser']

[org/gnome/gedit/plugins/filebrowser]
root='file:///'
tree-view=true
virtual-root='file:///home/u'

[org/gnome/gedit/preferences/editor]
auto-save-interval=uint32 10
editor-font='Monospace 9'
scheme='oblivion'
use-default-font=false

[org/gnome/gedit/preferences/print]
print-font-body-pango='Monospace 9'
print-font-header-pango='Sans 11'
print-font-numbers-pango='Sans 8'
print-header=true
print-line-numbers=uint32 0
print-syntax-highlighting=true
print-wrap-mode='word'

[org/gnome/gedit/preferences/ui]
notebook-show-tabs-mode='always'
statusbar-visible=true

[org/gnome/gedit/state/window]
bottom-panel-size=140
side-panel-active-page=228660812
side-panel-size=200
size=(442, 988)
state=128

[org/gnome/glchess]
height=550
maximized=true
piece-theme='simple'
show-3d=false
show-history=true
show-move-hints=false
show-numbering=true
show-toolbar=false
width=500

[org/gnome/gnome-panel/layout]
object-id-list=['menu-bar', 'indicators', 'show-desktop', 'window-list', 'workspace-switcher']
toplevel-id-list=['top-panel', 'bottom-panel']

[org/gnome/gnome-panel/layout/objects/indicators]
object-iid='IndicatorAppletCompleteFactory::IndicatorAppletComplete'
pack-index=0
pack-type='end'
toplevel-id='top-panel'

[org/gnome/gnome-panel/layout/objects/menu-bar]
object-iid='PanelInternalFactory::MenuBar'
pack-index=0
toplevel-id='top-panel'

[org/gnome/gnome-panel/layout/objects/show-desktop]
object-iid='WnckletFactory::ShowDesktopApplet'
pack-index=0
toplevel-id='bottom-panel'

[org/gnome/gnome-panel/layout/objects/window-list]
object-iid='WnckletFactory::WindowListApplet'
pack-index=1
toplevel-id='bottom-panel'

[org/gnome/gnome-panel/layout/objects/workspace-switcher]
object-iid='WnckletFactory::WorkspaceSwitcherApplet'
pack-index=0
pack-type='end'
toplevel-id='bottom-panel'

[org/gnome/gnome-panel/layout/toplevels/bottom-panel]
animation-speed='fast'
auto-hide=false
auto-hide-size=1
enable-arrows=true
enable-buttons=false
expand=true
hide-delay=300
monitor=0
orientation='bottom'
screen=0
size=24
unhide-delay=100
x=0
x-centered=false
x-right=-1
y=1026
y-bottom=0
y-centered=false

[org/gnome/gnome-panel/layout/toplevels/top-panel]
animation-speed='fast'
auto-hide=false
auto-hide-size=1
enable-arrows=true
enable-buttons=false
expand=true
hide-delay=300
monitor=0
orientation='top'
screen=0
size=24
unhide-delay=100
x=0
x-centered=false
x-right=-1
y=0
y-bottom=-1
y-centered=false

[org/gnome/gnome-screenshot]
border-effect='none'
delay=2
include-border=false
include-pointer=false
last-save-directory='file:///home/u/Dropbox/Public'

[org/gnome/gnome-system-monitor]
current-tab=1
height=495
show-all-fs=true
view-as=1
width=725
x-position=874
y-position=422

[org/gnome/gnome-system-monitor/disktreenew]
columns-order=[0, 1, 2, 3, 4, 5, 6]
sort-col=1
sort-order=0

[org/gnome/gnome-system-monitor/memmapstree]
sort-col=0
sort-order=0

[org/gnome/gnome-system-monitor/openfilestree]
sort-col=0
sort-order=0

[org/gnome/gnome-system-monitor/proctree]
col-0-width=345
col-1-width=57
col-12-width=40
col-15-width=82
col-22-width=97
col-8-width=70
columns-order=[0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22]
sort-col=15
sort-order=0

[org/gnome/libgnomekbd/keyboard]
layouts=['us']
options=@as []

[org/gnome/libgnomekbd/preview]
height=545
width=1284
x=210
y=131

[org/gnome/nautilus/list-view]
default-column-order=['name', 'size', 'type', 'date_modified', 'date_accessed', 'group', 'where', 'mime_type', 'octal_permissions', 'owner', 'permissions']
default-visible-columns=['name', 'size', 'type', 'date_modified']

[org/gnome/nautilus/preferences]
always-use-location-entry=true
enable-delete=true
show-advanced-permissions=true
show-hidden-files=true

[org/gnome/nautilus/window-state]
geometry='800x550+0+0'
maximized=false
start-with-sidebar=true

[org/gnome/rhythmbox/library/source]
show-browser=true
sorting=('Artist', true)

[org/gnome/rhythmbox/player]
volume=1.0

[org/gnome/rhythmbox/plugins]
active-plugins=['generic-player', 'daap', 'ubuntuone', 'power-manager', 'audioscrobbler', 'mmkeys', 'cd-recorder', 'audiocd', 'rb', 'mtpdevice', 'ipod', 'notification', 'iradio', 'artdisplay', 'mpris', 'artsearch', 'dbus-media-server']
seen-plugins=['daap', 'fmradio', 'ubuntuone', 'audioscrobbler', 'cd-recorder', 'pythonconsole', 'rb', 'rblirc', 'mtpdevice', 'rbzeitgeist', 'ipod', 'notification', 'lyrics', 'artdisplay', 'context', 'mpris', 'sendto', 'im-status', 'artsearch', 'magnatune', 'dbus-media-server', 'replaygain']

[org/gnome/rhythmbox/plugins/audioscrobbler]
Last.fmscrobbling-enabled=true
Libre.fmscrobbling-enabled=true

[org/gnome/rhythmbox/plugins/ipod/source]
show-browser=true
sorting=('Artist', true)

[org/gnome/rhythmbox/plugins/iradio]
initial-stations-loaded=true

[org/gnome/rhythmbox/plugins/iradio/source]
show-browser=true

[org/gnome/rhythmbox/podcast/source]
show-browser=true

[org/gnome/rhythmbox]
position=(0, 27)

[org/gnome/rhythmbox/rhythmdb]
locations=['file:///home/u/Music', 'file:///home/u/.ubuntuone/Purchased%20from%20Ubuntu%20One']

[org/gnome/settings-daemon/peripherals/keyboard]
numlock-state='off'

[org/gnome/settings-daemon/peripherals/touchpad]
horiz-scroll-enabled=true
scroll-method='two-finger-scrolling'

[org/gnome/settings-daemon/plugins/power]
critical-battery-action='shutdown'
idle-dim-battery=true
lid-close-battery-action='suspend'
sleep-display-ac=0
sleep-display-battery=0
sleep-inactive-battery-timeout=3600

[org/gnome/shell]
favorite-apps=['nautilus.desktop', 'yelp.desktop']

[org/gtk/settings/color-chooser]
selected-color=(true, 0.93725490196078431, 0.16078431372549021, 0.16078431372549021, 1.0)

[org/gtk/settings/file-chooser]
last-folder-uri=''
location-mode='path-bar'
show-hidden=false
show-size-column=true
sort-column='name'
sort-order='ascending'
window-position=(0, 184)
window-size=(840, 675)

[org/gwibber/state]
height=600
position-x=50
position-y=24
width=400

[system/locale]
region='en_US.utf8'

[system/proxy]
use-same-proxy=false

I see nothing relating to 'd'.

I went into org.gnome.desktop.wm.keybindings using dconf-editor and looked at my keyboard shortcuts. Nothing is set to ['d']. I have no clue why this is happening now that I've seen the system is saying it's not the keyboard shortcuts.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I had the same problem with 12.10 over a nginx X connection. I guess whats happening is that you don't have a super key on your keyboard and then it gets dropped, so that a "<Super>d" shortcut becomes just "d".

Open dconf-editor and navigate to org/gnome/desktop/wm/keybindings

You should see a list with all gnome shortcuts. I've changed all occurrences of <Super> to <Primary> (which is the cmd-key on my mac-keyboard) and got rid of the problem.

share|improve this answer
    
I'm no longer running Gnome 3 (well, I may be--haven't been on the partition). So, I can't really check to see if that works. I greatly appreciate the time you put into this answer, and I've accepted it despite my inability to verify it. –  000 Mar 10 '13 at 13:34
    
+1 a new user verified that this works. I've flagged that answer-comment, so it will get deleted soon. –  muru yesterday

Perhaps somehow a keyboard shortcut got set to 'd'. Try using dconf Editor to change the shortcut in question back using dconf-editor.

To see all the currently set non-default dconf settings, run dconf dump / look for something whose value is 'd' or something like that.

share|improve this answer
    
I ran that command and posted the results in my answer. What do you think? –  000 Nov 25 '12 at 18:32
    
I don't see anything that would indicate d is set to...Is your keyboard map set properly? I'm not sure what the issue is otherwise, sorry. –  hnasarat Nov 25 '12 at 20:14
    
Yep, I am fairly certain it's set properly. I even uninstalled compiz to see if there was a conflict between compiz and GNOME 3, but that didn't do anything. I believe there is some sort of error in the GNOME 3's communication between the settings prompt and the actual thing that controls the function of the keyboard keys, but I'm not a qualified Linux (or even computer) user and my opinion may be completely off base. –  000 Nov 25 '12 at 20:53
    
you could try completely uninstalling gnome-shell and seeing if that fixes anything. Gnome-shell is the only DE (desktop environment) that has this problem, right? If so, remove it with sudo apt-get purge gnome-shell. You can then install it again with sudo apt-get install gnome-shell and see if that helps. –  hnasarat Nov 26 '12 at 1:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.