Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I love my Asus Eee PC 1000 Ubuntu 12.04 netbook, but I have a little problem. As I use it, the screen will randomly turn grey and become unresponsive. I can then only wait, until perhaps 10-60 secs. later, when I can interact again. Only the bar at the top of my screen retains its colour throughout.

I thought it might be Firefox, as I have a lot of tabs open. I installed Chromium, used it instead, and the problem remained.

A while back I upgraded from 1 to 2 Gb RAM. So, I thought recently, maybe I should increase the swap-space. I have 738Mb of 7.2Gb free on root; and 2Gb of 28Gb free on my home drive. I bought a 32 Gb SD Card and assigned 4Gb to swap space. cat /proc/swaps reports that the partition is being used. Alas the problem remains. Does anyone know what's wrong with my machine?

The SD Card has changed my machine somewhat, but the greying still happens. I ran free -m shortly after another episode, and received:

             total       used       free     shared    buffers     cached
Mem:          2004       1731        272          0        370        769
-/+ buffers/cache:        591       1412
Swap:         4073          0       4073

Update: Using 'top', I can see that compiz uses about 43% of the CPU (#1 position) when the greying occurs. After the greying, compiz drops back down to its usual 8% of CPU.

Update: If I log in to Ubuntu using the Unity2d option (the option pops up when you press the Ubuntu logo on the login screen) instead of Unity, compiz is not loaded, and the problem disappears. Now Firefox's plugin-container is annoying me. I used about:config and changed dom.ipc.plugins.enabled to false. Now Firefox crashes often. Could it finally be time for Chromium? Alas I love Firefox's RSS support.

share|improve this question
up vote 0 down vote accepted

You can check memory and swap space usage with

free -m

If in doubt post it into your question and we'll have a look. It does sound like the application is busy and going non-responsive. It helps to have a look at CPU usage when this happens and see exactly what is going on. I run Gkrellm all the time on my systems, and use the terminal command 'top' to look at processes that are using the highest cpu. There may be another process that is using a lot of cpu occasionally, resulting in the problem with the browsers. Once you know what is causing the problem the suggestion usually suggests itself.

share|improve this answer
Thanks. I've installed gkrellm and tried running 'top' constantly, then ALT-TAB-ing back to it when the greying appears. I still haven't caught it. I'm not even sure if I should be watching the %CPU; VIRT; or RES. Please let me know if there's anything else I can provide. – user643722 Nov 25 '12 at 20:20
%cpu usually tells you when the system is struggling with something. Gkrellm uses different colours to show which areas are using cpu - system, user, or 'nice' which is usually daemon processes with a high nice value. You can then use top to see what processes are causing it. There's no problem with memory in the stats you posted, as it indicates 1412 MiB available for use. I've tried Chromium in the past on my Celeron machines but it didn't make enough of a difference to really matter. You may find that it helps however. – fabricator4 Dec 1 '12 at 19:15
I now have a shiny new Dell XPS 9333 laptop running Ubuntu 14.04 and this still happens - though far less often that with the Eee. Regardless of the state of my laptop, I assume someone knows what it is that this greying signifies - or which section of the OS is responsible. – user643722 Oct 14 '14 at 20:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.