Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Alright, I've already installed the nvidia drivers a while ago and had to deactivate them again because I couldn't change the resolution.

Now I would like to activate them again for HDMI support. The additional drivers window says that the driver nvidia-current is activated, but not in use. What is needed to use it as the primary driver again? I've already checked the Internet, but couldn't find any help.

Edit: If I run nvidia-xconfig and relog, my resolution freezes at 640x480 and I can't change it anywhere. Heres the content of my xorg.conf, since that seems to be causing the problem. As soon as I delete the xorg.conf, everything is back to normal again, but without nvidia drivers.

xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.64  (buildmeister@swio-display-x86-rhel47-12)  Tue Oct 30 12:04:46 PDT 2012


Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Monitor0"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection
share|improve this question
    
did you ever get the nvidia drivers working? I am having the same problem, exactly as you describe it. –  KenB Apr 17 '13 at 23:08
    
No, I didn't get it to work properly. fabricator4 was pointing out that the Horizontal Sync and Vertical Refresh may be wrong, but since I'm using a laptop I didn't find the proper values anywhere. –  Stuffy Apr 18 '13 at 12:01
    
I am also on a laptop, and have since figured that the problem relates to the hybrid intel/nvidia optimus graphics setup I have. Apparently there is this "bumblebee" software (bumblebee-project.org) that can be used to force programs to run using the more advanced nvidia graphics, but I rather doubt you could get HDMI support going that route. I've given up, and am booting into Windows (ouch) for high-end graphics / HDMI needs. –  KenB Apr 20 '13 at 15:50
    
That's exactly what I'm doing. I'm running bumblebee, but it has, as you mentioned, no HDMI-Support. Thus, I'm also forced to boot to windows if I want to use external monitors or want to watch/play HD movies or games. –  Stuffy Apr 22 '13 at 14:21
add comment

1 Answer

Run Nvidia-settings and configure the driver for your settings. Save the settings and it will write out the xorg.conf file which will be activated on your next login.

If you need to re-install the drivers:

sudo apt-get --reinstall install nvidia-current

If nvidia-settings hasn't already been installed:

sudo apt-get install nvidia-settings

You might also try the updated drivers:

sudo apt-get install nvidia-current-updates

and to remove them again:

sudo apt-get remove nvidia-current-updates

In general a remove and install should reinstall and re-configure the modules. You should also be able to do the same thing from 'additional drivers' if you want a GUI solution.

share|improve this answer
    
I've did that, and now my display-resolution is locked at 640x480 and I can't change it in the settings. What went wrong there? –  Stuffy Nov 25 '12 at 14:23
    
I've updated my question with the content of my xorg.conf, because it seems like that is causing the problem –  Stuffy Nov 25 '12 at 14:31
    
do sudo apt-get install linux-headers<tab> before installing nvidia –  type Nov 25 '12 at 14:39
    
Yes, the Hoziontal Sync and Vertical Refresh figures don't look right. Have a look at the specs for you monitor and enter them correctly. Once you've done that you will be able to select different resolutions in nvidia-settings. A lot of monitors now have these specs on an information page in the setup menus, but you will also find them in the manual and by googling the specs for your monitor. –  fabricator4 Nov 25 '12 at 19:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.