Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I keep reading the many similar problems, but the solutions and recommendations are not successful for me. I thought maybe it was a network problem, but no port is blocked. I finally took of all firewall and still a problem. I have changed sources from US servers, Main Server, and even let Update Manage look for a best server. Still have problem.

Here is what I get:

thyme@thyme-Inspiron-1545:~$ sudo apt-get update
[sudo] password for thyme: 
Ign ttp://security.ubuntu.com precise-security InRelease
Ign ttp://archive.ubuntu.com precise InRelease
Hit ttp://security.ubuntu.com precise-security Release.gpg
Hit ttp://archive.ubuntu.com precise Release.gpg
Hit ttp://security.ubuntu.com precise-security Release
Hit ttp://archive.ubuntu.com precise Release   
Hit ttp://security.ubuntu.com precise-security/universe i386 Packages
Hit ttp://archive.ubuntu.com precise/main i386 Packages
Hit ttp://security.ubuntu.com precise-security/main i386 Packages
Hit ttp://security.ubuntu.com precise-security/main TranslationIndex
Hit ttp://security.ubuntu.com precise-security/universe TranslationIndex
Hit ttp://security.ubuntu.com precise-security/main Translation-en
Hit tp://security.ubuntu.com precise-security/universe Translation-en
Hit ttp://archive.ubuntu.com precise/universe i386 Packages
Hit ttp://archive.ubuntu.com precise/main TranslationIndex
Hit ttp://archive.ubuntu.com precise/universe TranslationIndex
Hit ttp://archive.ubuntu.com precise/main Translation-en
Hit ttp://archive.ubuntu.com precise/universe Translation-en
Reading package lists... Done
thyme@thyme-Inspiron-1545:~$ 

thyme@thyme-Inspiron-1545:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  linux-generic-pae linux-headers-generic-pae linux-image-generic-pae
The following packages will be upgraded:
  accountsservice apparmor apt apt-transport-https apt-utils bind9-host dbus
  dbus-x11 dnsutils firefox firefox-globalmenu firefox-gnome-support
  firefox-locale-en fonts-opensymbol gir1.2-javascriptcoregtk-3.0
  gir1.2-rb-3.0 gir1.2-webkit-3.0 gnupg gpgv isc-dhcp-client isc-dhcp-common
  krb5-locales libaccountsservice0 libapt-inst1.4 libapt-pkg4.12 libbind9-80
  libc-bin libc-dev-bin libc6 libc6-dev libdbus-1-3 libdns81 libexif12
  libexpat1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libglu1-mesa
  libgssapi-krb5-2 libisc83 libisccc80 libisccfg82 libjavascriptcoregtk-3.0-0
  libk5crypto3 libkrb5-3 libkrb5support0 liblwres80 libnss3 libproxy1
  libproxy1-plugin-gsettings libproxy1-plugin-networkmanager libpurple-bin
  libpurple0 libqt4-dbus libqt4-declarative libqt4-network libqt4-opengl
  libqt4-script libqt4-sql libqt4-sql-sqlite libqt4-svg libqt4-xml
  libqt4-xmlpatterns libqtcore4 libqtgui4 libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-math
  libreoffice-style-human libreoffice-style-tango libreoffice-writer
  librhythmbox-core5 libsmbclient libsnmp-base libsnmp15 libssl1.0.0
  libsyncdaemon-1.0-1 libtasn1-3 libtiff4 libunity-2d-private0 libwbclient0
  libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libxatracker1 libxml2 libxslt1.1
  linux-libc-dev multiarch-support openssl python-crypto python-keyring
  python-libproxy python-libxml2 python-software-properties
  python-ubuntuone-client python-ubuntuone-storageprotocol python-uno qdbus
  rhythmbox rhythmbox-data rhythmbox-mozilla rhythmbox-plugin-cdrecorder
  rhythmbox-plugin-magnatune rhythmbox-plugin-zeitgeist rhythmbox-plugins
  samba-common samba-common-bin smbclient software-properties-common
  software-properties-gtk sudo thunderbird thunderbird-globalmenu
  thunderbird-gnome-support transmission-common transmission-gtk tzdata
  ubuntuone-client unity-2d unity-2d-common unity-2d-panel unity-2d-shell
  unity-2d-spread uno-libs3 update-manager update-manager-core ure xdiagnose
  xserver-common xserver-xorg-core xul-ext-ubufox
139 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 203 MB/219 MB of archives.
After this operation, 15.8 MB of additional disk space will be used.
Do you want to continue [Y/n]?

Had to take rest off because hassle to go in and disable links since as new user I am only allowed two links. Hard to give results with that restriction!

Essentially was continual similar response of:

Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/t/transmission/transmission-common_2.51-0ubuntu1.1_all.deb  Unable to connect to security.ubuntu.com:http: [IP: 91.189.92.184 80]

Please provide some guidance. I have been using ubuntu since 2007 and never had a problem upgrading or installing new releases. This has been three days working on this. Thanks in advance...

share|improve this question
add comment

1 Answer

I had the same problem. It was solved by changing to a server which uses https protocol.

Got a hint from this answer. The author provides a list of servers that use https

Note: I had to perform a "search and replace" on my sources.list as I could not find https mirrors via the GUI.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.