Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using 12.10 with gnome-shell 3.6.

I have multiple ssh keypairs (created with ssh-keygen). They're stored in ~/.ssh/ids/hostname/id_rsa and id_rsa.pub. I have a file ~/.ssh/config which says which key to use with which host.

Whenever I connect to one of the hosts, it always prompts me for the id_rsa password. I want the keys to be unlocked whenever I'm logged in.

I tried to import the keys into seahorse (aka Passwords and Keys), but I ran against this bug https://bugs.launchpad.net/ubuntu/+source/seahorse/+bug/1017210

I then tried to use ssh-add. This gave me the proper behavior, but it didn't persist across sessions/reboots.

Before I created different keys for different hosts, gnome-shell would give me a popup asking for my login password, and after I entered it, the keys would be unlocked for the rest of the session. How can I get this to work again?

share|improve this question
    
check out this link, make sure you correctly transfered the public key to the server help.ubuntu.com/community/SSH/OpenSSH/… –  Sam Nov 24 '12 at 23:52
    
I did correctly transfer them. As I mentioned, when I used ssh-add to unlock the private keys, I could log in to the various hosts with no problem (and no password, either from my account on that host and from the keyfile). –  hnasarat Nov 25 '12 at 0:13
add comment

1 Answer

Seahorse will automatically detect the ssh keyfiles if they're in the top-level ~/.ssh directory. My work-around solution was to change how I organized my keyfiles. As such, seahorse detects them, and gnome-shell detects them only asks for my login password once per keyfile.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.