Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay guys, so i've looked around extensively on this topic, only to find that no one has a true solution, only half explained work arounds. Something tells me this problem can be solved, for the pure reason that i " CAN " change my wifi-cards MAC address in windows 7 both manually and using Iron Geeks madMACS. So this leads me to investigate, why after changing my mac on ubuntu 10.04/10.10/12.04/Backtrack 5 r2/r3 why I can not connect.

Please note that this is not a problem of my router, I have tried it on multiple public access points, and with my changed MAC, I can not even connect to an open network. I've read somewhere that you have to change the mac before the wifi-card's true MAC is released in BIOS. Is this true? This is the only logical explanation I can think of right now.

I don't mind going out and buying a new wifi-card that does support ubuntu MAC cloning. If any one has one working out of the box please let me know.

description: Wireless interface product: BCM4313 802.11b/g/n Wireless LAN Controller

   vendor: Broadcom Corporation

   physical id: 0

   bus info: pci@0000:02:00.0

   logical name: wlan0

   version: 01

   serial: c0:18:85:43:c6:e4

   width: 64 bits

   clock: 33MHz

   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless

   configuration: broadcast=yes driver=brcmsmac driverversion=3.2.0-29-generic-pae firmware=N/A ip=10.1.1.8 latency=0

   link=yes multicast=yes wireless=IEEE 8 '

I have tried both Network-Manager & WICD both failing.

I use Acer Aspire D-270, first off i couldn't even change my MAC address, got the error of device busy etc. But then i added the macchange to startup now the mac changes but it just wont connect till i set it back to original mac.

share|improve this question
    
Could it be, that you change the MAC address to something illegal? Can you post what you change it to, or the exact command you use. –  mikewhatever Nov 25 '12 at 0:11
    
I don't believe brcmsmac is the ideal driver for your device. Please run lspci -nn. Is the pci.id 14e4:4727? If so, I think the STA driver is correct. Having said that, I have no idea if you can change the MAC there either. You certainly can connect better. I doubt being able to connect has anything to do with the MAC and everything to do with the driver. Would you like to change the driver? –  chili555 Nov 25 '12 at 2:01
    
Mikewhatever - Hi Mike, I truly appreciate your good samaritan like behavior however it's comment's like this that tend to waste users time and effort. All that aside, i've tried both " sudo ifconfig wlan0 hw ether xx:xx:xx:xx:xx:xx & i've also downloaded "macchanger" and added it to startup function yet still neither work. –  James Bond Nov 25 '12 at 8:51
    
Chili555 - Thankyou for your input Chilli, I can appreciate your sensibility and are very grateful you have offered to help. I have tried to " run lspci-nn " & "lspci-nn" from terminal as ROOT. But it comes back "command not found". I understand what your saying "I doubt being able to connect has anything to do with the MAC and everything to do with the driver" However if the driver is the problem, Why can i connect "before" i change my MAC address. It's only 'After' i change my MAC is when i get no connectivity. But if you still think it's a driver issue im happy changing. –  James Bond Nov 25 '12 at 8:58
    
It is not lspci-nn. It is lspci -nn. There is a space between lspci and -nn. –  chili555 Nov 25 '12 at 12:39
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.