Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded my Ubuntu 12.10 with the GNOME 3 PPA (ppa:gnome3-team/gnome3). This has updated Totem to version 3.6.2. Since GNOME 3.6 has introduced its own global menus, I cannot find the Preferences option in Totem's menu now. I am using the default Unity global menu system. Any ideas on how to get Preferences back?

share|improve this question
1  
i'm not in gnome, but have you tried "h" key, it usually shows/hides controls? –  cipricus Nov 24 '12 at 21:01

3 Answers 3

I have a running machine with Unity Desktop and Totem 3.6. (but wiht global menu disable)
As you can see the menu bar is in the Totem's window, but also in unity I have a global menu called "Videos > Preferences".

enter image description here

Or you can set the focus on the totem's window,then use the "Hud" (press the Alt key) and type for "Preferences", then hit enter and the preferences windows will be open.

enter image description here

enter image description here

Tested with "global menu enable" the "Hud" brings the "preferences window" enter image description here

Hope this will helpful.

share|improve this answer

Or, if you really need the menu back, you could downgrade totem and all it's sub-packages and plugins, to version 3.4.3-0ubuntu5 and lock the version from any updates. Launch Synaptic, search for totem and select all *totem* 3.6.* files, go to Force verion, then mark the files as Locked in the Package menu.

share|improve this answer

Open a terminal and launch Totem like this:

UBUNTU_MENUPROXY=0 totem

This will disable the global menu for Totem, so the menu that used to show up on the top Unity panel will show up inside the Totem window, but the GNOME "Gmenu" will now show up on the op panel - click it and there you should find the preferences menu along with a few other items.

Screenshot:

enter image description here

To always run Totem like this, open its desktop file as root: gksu gedit /usr/share/applications/totem.desktop

And change "Exec=totem %U" (it should be on line 5) to "UBUNTU_MENUPROXY=0 totem %U", then save the file.

Via: How To Disable The GNOME Shell AppMenu While Retaining Its Functionality

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.